HDU 1042 N!(高精度)

24 篇文章 0 订阅

Description
给出n,输出n!
Input
多组输入,每组用例占一行为一整数n,以文件尾结束输入
Output
对于每个n,输出n!
Sample Input
1
2
3
Sample Output
1
2
6
Solution
高精度乘法
Code

#include<cstdio>
#include<iostream>
#include<algorithm>
#include<cstring>
#include<cmath>
#include<queue>
#include<stack>
#include<map>
#include<vector>
#include<string>
using namespace std;
#define maxn 36666
#define INF 0x3f3f3f3f
typedef long long ll;
int f[maxn];
int main()
{
    int n;
    while(scanf("%d",&n)!=EOF)
    {
        memset(f,0,sizeof(f));//初始化 
        f[0]=1;
        for(int i=2;i<=n;i++)
        {
            int k=0;//进位值 
            for(int j=0;j<maxn;j++)
            {
                int temp=f[j]*i+k;
                f[j]=temp%10;
                k=temp/10;
            }
        }
        int j;
        for(j=maxn-1;j>=0;j--)//去掉前置0 
            if(f[j])
                break;
        for(int i=j;i>=0;i--)
            printf("%d",f[i]);
        printf("\n"); 
    }
    return 0;
}  
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值