GYM 101086 H.Another Square in the Floor(水~)

253 篇文章 2 订阅

Description
给出一个x*y的矩形,求一个各边分别平行于该矩形且能够覆盖该矩形的最小正方形的面积
Input
第一行一整数T表示用例组数,每组用例输入两个整数x和y表示矩形相邻两边边长(1<=T<=1024,1<=x,y<=1000)
Output
输出满足条件的正方形的面积
Sample Input
3
3 3
5 7
12 6
Sample Output
9
49
144
Solution
水题,ans=max(x,y)^2
Code

#include<cstdio>
#include<iostream>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<vector>
#include<queue>
#include<map>
#include<set>
#include<ctime>
using namespace std;
typedef long long ll;
#define INF 0x3f3f3f3f
#define maxn 1111
int main()
{
    int T,x,y;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d%d",&x,&y);
        x=max(x,y);
        printf("%d\n",x*x);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值