CodeForces 638 A.Home Numbers(水~)

Description
n个房子如下图放置,问去编号为a的房子最短要走多少米
这里写图片描述
Input
两个整数n和a表示房子数和要去的房子的编号(1<=a<=n<=1e5)
Output
输出去编号为a的房子最短要走多少米
Sample Input
4 2
Sample Output
2
Solution
水题,去奇数房需走(a+1)/2米,去偶数房需走(n-a)/2+1米
Code

#include<cstdio>
#include<iostream>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<vector>
#include<queue>
#include<map>
#include<set>
#include<ctime>
using namespace std;
typedef long long ll;
#define INF 0x3f3f3f3f
#define maxn 1111
int main()
{
    int n,a;
    while(~scanf("%d%d",&n,&a))
    {
        if(a%2)printf("%d\n",(a+1)/2);
        else printf("%d\n",(n-a)/2+1);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值