CodeForces 651 A.Joysticks(贪心)

Description
两个数a和b,每一轮可以选择一个数让其减2,另一个数加一,当一个数为0或者两个数不够减2的时候结束,问最多可以进行多少轮
Input
两个数a和b(1<=a,b<=100)
Output
输出最多可以进行多少轮
Sample Input
3 5
Sample Output
6
Solution
贪心,每次选较大值减2
Code

#include<cstdio>
#include<iostream>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<vector>
#include<queue>
#include<map>
#include<set>
#include<ctime>
using namespace std;
typedef long long ll;
#define INF 0x3f3f3f3f
#define maxn 111
int a,b;
int main()
{
    while(~scanf("%d%d",&a,&b))
    {
        int ans=0;
        if(!(a==1&&b==1))
            while(a>0&&b>0)
            {
                ans++;
                if(a<b)a++,b-=2;
                else a-=2,b++;
            }
        printf("%d\n",ans);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值