CodeForces 339 A.Helpful Maths(水~)

Description

给出一个1,2,3的求和式,要求把被加数排完序后输出该求和式

Input

一个1,2,3的求和式s,串长不超过100

Output

输出有序的求和式

Sample Input

1+1+3+1+3

Sample Output

1+1+1+3+3

Solution

水题,把数字拿出来排个序然后从小到大输出即可

Code

#include<cstdio>
#include<iostream>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<vector>
#include<queue>
#include<map>
#include<set>
#include<ctime>
using namespace std;
typedef long long ll;
typedef pair<int,int>P;
const int INF=0x3f3f3f3f,maxn=100001;
char s[maxn];
int res,a[maxn];
int main()
{
    while(~scanf("%s",s))
    {
        int n=strlen(s);
        res=0;
        for(int i=0;i<n;i+=2)a[res++]=s[i]-'0';
        sort(a,a+res);
        for(int i=0;i<res-1;i++)printf("%d+",a[i]);
        printf("%d\n",a[res-1]);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值