CodeForces 266 A.Stones on the Table(水~)

Description

一排 n 个石头,第i个石头颜色为 s[i] ,要求相邻两块石头必须颜色不用,问至少要拿走多少块石头

Input

第一行一整数 n 表示石头个数,之后输入一个长度为n的字符串 s 表示每个石头的颜色(1n50)

Output

输出至少要拿走的石头数量

Sample Input

3
RRG

Sample Output

1

Solution

水题,相邻两个重复就拿走一个

Code

#include<cstdio>
#include<iostream>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<vector>
#include<queue>
#include<map>
#include<set>
#include<ctime>
using namespace std;
typedef long long ll;
typedef pair<int,int>P;
const int INF=0x3f3f3f3f,maxn=100001;
char s[maxn];
int main()
{
    int n;
    while(~scanf("%d",&n))
    {
        scanf("%s",s);
        int num=0;
        for(int i=1;i<n;i++)if(s[i]==s[i-1])num++;
        printf("%d\n",num);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值