Description
有
m
个团队,第
Input
第一行三个整数
Output
如果人数不够组队则输出 −1 ,否则输出组成满足条件队伍的概率
Sample Input
3 2 1
2 2
Sample Output
0.666667
Solution
令 s=∑i=1mai
如果 s<n 显然输出 −1
如果
s−ah<n−1
则必然需要从第
h
个团队中选取至少两个人,答案是
否则 ans=Cn−1s−ahCn−1s−1=∏i=1n−1s−ah−n+1+is−n+i
Code
#include<cstdio>
#include<iostream>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<vector>
#include<queue>
#include<map>
#include<set>
#include<ctime>
using namespace std;
typedef long long ll;
typedef pair<int,int>P;
const int INF=0x3f3f3f3f,maxn=100001;
int main()
{
int n,m,h;
while(~scanf("%d%d%d",&n,&m,&h))
{
int s=0,ah;
for(int i=1;i<=m;i++)
{
int a;
scanf("%d",&a);
if(i==h)ah=a;
s+=a;
}
s--;n--;ah--;
if(s<n)printf("-1\n");
else if(s-ah<n)printf("1\n");
else
{
double ans=1;
for(int i=1;i<=n;i++)ans=ans*(s-ah-n+i)/(s-n+i);
ans=1.0-ans;
printf("%.12f\n",ans);
}
}
return 0;
}