CodeForces 107 B.Basketball Team(水~)

Description

m 个团队,第i个团队中有 ai 个人,现在要从这些人中选出 n 个人组成一队,已知第h个团队中有一个人一定被选,问最终队伍中有不少于两个来自第 h 个团队的人的概率

Input

第一行三个整数n,m,h,之后输入 m 个整数ai表示第 i 个团队的人数(1n100,1m1000,1hm,1ai100)

Output

如果人数不够组队则输出 1 ,否则输出组成满足条件队伍的概率

Sample Input

3 2 1
2 2

Sample Output

0.666667

Solution

s=i=1mai

如果 s<n 显然输出 1

如果 sah<n1 则必然需要从第 h 个团队中选取至少两个人,答案是1

否则 ans=Cn1sahCn1s1=i=1n1sahn+1+isn+i

Code

#include<cstdio>
#include<iostream>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<vector>
#include<queue>
#include<map>
#include<set>
#include<ctime>
using namespace std;
typedef long long ll;
typedef pair<int,int>P;
const int INF=0x3f3f3f3f,maxn=100001;
int main()
{
    int n,m,h;
    while(~scanf("%d%d%d",&n,&m,&h))
    {
        int s=0,ah;
        for(int i=1;i<=m;i++)
        {
            int a;
            scanf("%d",&a);
            if(i==h)ah=a;
            s+=a;
        }
        s--;n--;ah--;
        if(s<n)printf("-1\n");
        else if(s-ah<n)printf("1\n");
        else 
        {
            double ans=1;
            for(int i=1;i<=n;i++)ans=ans*(s-ah-n+i)/(s-n+i);
            ans=1.0-ans;
            printf("%.12f\n",ans);
        }

    } 
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值