CodeForces 319 A.Malek Dance Club(组合数学)

Description

给序列 0,1,...,2n1 都异或上 x 后,问逆序对数

Input

一个长度为n 01 串表示 x 的二进制表示(1n100)

Output

输出逆序对数,结果模 109+7

Sample Input

11

Sample Output

6

Solution

如果 x i位为 1 ,那么在该位大小关系反转的数对有2i22(ni1)=22ni2,因为这两个数第 0 ~i1位必须相同,第 i+1 ~ n1 位随便取,然后在第 i 位一个是0一个是 1 <script type="math/tex" id="MathJax-Element-18">1</script>

Code

#include<cstdio>
#include<iostream>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<vector>
#include<queue>
#include<map>
#include<set>
#include<ctime>
using namespace std;
typedef long long ll;
typedef pair<int,int>P;
const int INF=0x3f3f3f3f,maxn=205;
#define mod 1000000007
int f[maxn];
void init(int n=200)
{
    f[0]=1;
    for(int i=1;i<=n;i++)f[i]=2*f[i-1]%mod;
}
char s[maxn];
int main()
{
    init();
    while(~scanf("%s",s))
    {
        int n=strlen(s),ans=0;
        for(int i=0;i<n;i++)
            if(s[i]=='1')ans=(ans+f[2*n-i-2])%mod;
        printf("%d\n",ans);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值