CodeForces 478 B.Random Teams(组合数学)

Description

n 个人分成m组,每组至少一人,组内人都成了好朋友,问所有方案中,朋友对数最少和最多分别是多少

Input

两个正整数 n,m(1mn109)

Output

输出最少朋友对数和最多朋友对数

Sample Input

3 2

Sample Output

1 1

Solution

C2x+C2y<C2x+y 知,最多时就是 m1 个人一人一组,剩下人一组,此时答案为 C2nm+1 ,最少时就是人数尽量均分,有 n%m 组有 nm 个人,有 mn%m 组有 nm ,以此计算出最少对数

Code

#include<cstdio>
#include<iostream>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<vector>
#include<queue>
#include<map>
#include<set>
#include<ctime>
using namespace std;
typedef long long ll;
typedef pair<int,int>P;
const int INF=0x3f3f3f3f,maxn=100001;
ll C(int n)
{
    return (ll)n*(n-1)/2;
}
int main()
{
    int n,m;
    while(~scanf("%d%d",&n,&m)) 
    {
        ll k1=(ll)(n%m)*C(n/m+1)+(ll)(m-n%m)*C(n/m);
        ll k2=C(n-m+1);
        printf("%I64d %I64d\n",k1,k2);
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值