GYM 101606 I.I Work All Day(水~)

253 篇文章 2 订阅

Description

给出 n n 个整数hi和一整数 T T ,问T%hi的最小值

Input

第一行一整数 n n 表示整数个数,之后输入n个整数 hi h i 和一个整数 T T

(2n10,1hi500,1T3000)

Output

输出使得 T%hi T % h i 最小的 hi h i ,如果多组解则输出 hi h i 的最小值

Sample Input

3
5 6 8
103

Sample Output

6

Solution

水题

Code

#include<cstdio>
#include<iostream>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<vector>
#include<queue>
#include<map>
#include<set>
#include<ctime>
using namespace std;
typedef long long ll;
typedef pair<int,int>P;
const int INF=0x3f3f3f3f,maxn=105;
int n,h[maxn],t;
int main()
{
    scanf("%d",&n);
    for(int i=1;i<=n;i++)scanf("%d",&h[i]);
    scanf("%d",&t);
    int ans=1;
    for(int i=2;i<=n;i++)
        if(t%h[i]<t%h[ans])ans=i;
    printf("%d\n",h[ans]);
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值