Newcoder 84 A.字典序最大的子序列(单调栈)

Description

给定字符串 s s s s s s只包含小写字母,请求出字典序最大的子序列。

Input

一行一个字符串 s s s

$ (1 \le |s| \le 10^5)$

Output

字典序最大的子序列。

Sample Input

ababba

Sample Output

bbba

Solution

s s s维护一个不增的单调栈即可

Code

#include<cstdio>
#include<cstring>
using namespace std;
const int maxn=100005;
char s[maxn],c[maxn];
int main()
{
	scanf("%s",s);
	int p=0,n=strlen(s);
	for(int i=0;i<n;i++)
	{
		while(p&&s[i]>c[p-1])p--;
		c[p++]=s[i];
	}
	c[p]='\0';
	printf("%s\n",c);
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值