HDU - 1160 M - FatMouse's Speed

FatMouse believes that the fatter a mouse is, the faster it runs. To disprove this, you want to take the data on a collection of mice and put as large a subset of this data as possible into a sequence so that the weights are increasing, but the speeds are decreasing. 

Input

Input contains data for a bunch of mice, one mouse per line, terminated by end of file. 

The data for a particular mouse will consist of a pair of integers: the first representing its size in grams and the second representing its speed in centimeters per second. Both integers are between 1 and 10000. The data in each test case will contain information for at most 1000 mice. 

Two mice may have the same weight, the same speed, or even the same weight and speed. 

Output

Your program should output a sequence of lines of data; the first line should contain a number n; the remaining n lines should each contain a single positive integer (each one representing a mouse). If these n integers are m[1], m[2],..., m[n] then it must be the case that 

W[m[1]] < W[m[2]] < ... < W[m[n]] 

and 

S[m[1]] > S[m[2]] > ... > S[m[n]] 

In order for the answer to be correct, n should be as large as possible. 
All inequalities are strict: weights must be strictly increasing, and speeds must be strictly decreasing. There may be many correct outputs for a given input, your program only needs to find one. 

Sample Input

6008 1300
6000 2100
500 2000
1000 4000
1100 3000
6000 2000
8000 1400
6000 1200
2000 1900

Sample Output

4
4
5
9
7

题意:给出一些老鼠的体重和跑速,为了证明老鼠越重跑得越慢,要找一些数据,由若干个老鼠组成,保证老鼠的体重依次增加而跑速依次减小,问这些数据最多能有多少老鼠,并按体重从小到大输出这些老鼠的序号。

分析:建一个结构体记录每只老鼠的体重,速度和序号,然后按照老鼠的体重从小到大排序,然后用动态规划找最长的老鼠速度递减的长度,dp[j]表示前j只老鼠最长下降子序列,找出最大的dp[j],还要用数组记录老鼠的原始序号。

代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int dp[1010],f[1010],ans[1010];
struct node
{
    int w,v,d;     //体重  速度  序号
} q[1010];
bool cmp(node a,node b)
{
    if(a.w==b.w)
        return a.v>b.v;
    return a.w<b.w;
}
int main()
{
    int n=0;
    while(~scanf("%d%d",&q[n].w,&q[n].v))
    {
        q[n].d=n+1;
        n++;
    }
    sort(q,q+n,cmp);        //排序
    for(int i=0; i<n; i++)  //初始化
        dp[i]=1;            
    memset(f,0,sizeof(f));  

    for(int i=0; i<n; i++)    //遍历所有的老鼠
        for(int j=0; j<i; j++)
            if(q[i].w>q[j].w&&q[i].v<q[j].v&&dp[i]<dp[j]+1)//状态转移方程
            {
                dp[i]=dp[j]+1;
                f[i]=j;             //记录老鼠原始位置
            }
    int maxn=dp[0],t;
    for(int i=0; i<n; i++)        //找最大的f[i];
        if(dp[i]>maxn)
        {
            maxn=dp[i];
            t=i;
        }
    int v=1;
    printf("%d\n",maxn);
    while(t)
    {
        ans[v++]=t;            //记录老鼠的位置
        t=f[t];
    }
    v--;
    for(int i=v; i>0; i--)
        printf("%d\n",q[ans[i]].d);
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值