HDU 1160 FatMouse's Speed(DP)

题目链接:http://hdu.hustoj.com/showproblem.php?pid=1160

题目大意:输入到文件结束,每行一个老鼠的重量和速度,要求选最多只老鼠,重量依次增加,速度依次减小

Problem Description
FatMouse believes that the fatter a mouse is, the faster it runs. To disprove this, you want to take the data on a collection of mice and put as large a subset of this data as possible into a sequence so that the weights are increasing, but the speeds are decreasing.
 

Input
Input contains data for a bunch of mice, one mouse per line, terminated by end of file.

The data for a particular mouse will consist of a pair of integers: the first representing its size in grams and the second representing its speed in centimeters per second. Both integers are between 1 and 10000. The data in each test case will contain information for at most 1000 mice.

Two mice may have the same weight, the same speed, or even the same weight and speed. 
 

Output
Your program should output a sequence of lines of data; the first line should contain a number n; the remaining n lines should each contain a single positive integer (each one representing a mouse). If these n integers are m[1], m[2],..., m[n] then it must be the case that 

W[m[1]] < W[m[2]] < ... < W[m[n]]

and 

S[m[1]] > S[m[2]] > ... > S[m[n]]

In order for the answer to be correct, n should be as large as possible.
All inequalities are strict: weights must be strictly increasing, and speeds must be strictly decreasing. There may be many correct outputs for a given input, your program only needs to find one. 
 

Sample Input
 
 
6008 1300 6000 2100 500 2000 1000 4000 1100 3000 6000 2000 8000 1400 6000 1200 2000 1900
 

Sample Output
 
 
4 4 5 9 7
 

Source


思路:按照速度y从大到小排个序之后,就转化成求x的最长上升子序列了,记录一下idx,最后从后往前找递归输出

代码:

#include<cstdio>
#include<cmath>
#include<cstring>
#include<string>
#include<cstdlib>
#include<algorithm>
#include<iostream>
#include<queue>
#include<stack>
#include<map>

using namespace std;

#define FOU(i,x,y) for(int i=x;i<=y;i++)
#define FOD(i,x,y) for(int i=x;i>=y;i--)
#define MEM(a,val) memset(a,val,sizeof(a))
#define PI acos(-1.0)

const double EXP = 1e-9;
typedef long long ll;
typedef unsigned long long ull;
const int INF = 0x3f3f3f3f;
const ll MINF = 0x3f3f3f3f3f3f3f3f;
const int mod = 1e9+7;
const int N = 1e6+5;

struct node
{
    int x;
    int y;
    int idx;
}a[1005];

int ans[1005];
int ansy[1005];
int dp[1005];
int vis[1005];

bool cmp(node A,node B)
{
    if(A.y==B.y)
        return A.x<B.x;
    return A.y>B.y;
}

void output(int x,int now)
{
    if(x==0)
        return ;
    for(int i=now;i>=1;i--)
    {
        if(dp[i]==x)
        {
            output(x-1,i-1);
            printf("%d\n",a[i].idx);
            break;
        }
    }
}

int main()
{
    //freopen("in.txt","r",stdin);
    //freopen("out.txt","w",stdout);
    std::ios::sync_with_stdio(false);
    int cnt=1;
    while(~scanf("%d%d",&a[cnt].x,&a[cnt].y))
    {
        a[cnt].idx=cnt;
        cnt++;
    }
    cnt--;
    //printf("cnt=%d\n",cnt);
    sort(a+1,a+1+cnt,cmp);
    for(int i=1;i<=cnt;i++)
        dp[i]=1;
    int ans=1;
    for(int i=2;i<=cnt;i++)
    {
        for(int j=1;j<i;j++)
        {
            if(a[i].x>a[j].x&&a[i].y<a[j].y)
                dp[i]=max(dp[i],dp[j]+1);
        }
        ans=max(ans,dp[i]);
    }
    printf("%d\n",ans);
    int x=ans;
    output(ans,cnt);
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值