POJ 3255 Roadblocks --次短路 + spfa

Bessie has moved to a small farm and sometimes enjoys returning to visit one of her best friends. She does not want to get to her old home too quickly, because she likes the scenery along the way. She has decided to take the second-shortest rather than the shortest path. She knows there must be some second-shortest path.

The countryside consists of R (1 ≤ R ≤ 100,000) bidirectional roads, each linking two of the N (1 ≤ N ≤ 5000) intersections, conveniently numbered 1..N. Bessie starts at intersection 1, and her friend (the destination) is at intersection N.

The second-shortest path may share roads with any of the shortest paths, and it may backtrack i.e., use the same road or intersection more than once. The second-shortest path is the shortest path whose length is longer than the shortest path(s) (i.e., if two or more shortest paths exist, the second-shortest path is the one whose length is longer than those but no longer than any other path).

Input

Line 1: Two space-separated integers: N and R 
Lines 2.. R+1: Each line contains three space-separated integers: AB, and D that describe a road that connects intersections A and B and has length D (1 ≤ D ≤ 5000)

Output

Line 1: The length of the second shortest path between node 1 and node N

Sample Input

4 4
1 2 100
2 4 200
2 3 250
3 4 100

Sample Output

450

Hint

Two routes: 1 -> 2 -> 4 (length 100+200=300) and 1 -> 2 -> 3 -> 4 (length 100+250+100=450)

 

两次最短:

从起点跑一次最短路,然后再从终点跑一次最短路,然后遍历一遍所有的边,次短路的距离就是其中某条边的权值加上起点到一个点的最短路加上终点到另一个点的最短路

不要用数组建图,内存会炸,用结构体加邻接表来存

#include<iostream>
#include<string.h>
#include<queue>
#include<algorithm>
using namespace std;
#define ll long long
#define INF 0x3f3f3f3f
const int N=5010;
int n,m,head[N],dis[N],dis1[N],book[N],t;

struct node
{
    int u,v,w,next; 
}e[200010];

void add(int i,int j,int w)  //存图
{
    e[t].u=i;
    e[t].v=j;
    e[t].w=w;
    e[t].next=head[i];
    head[i]=t++;
}

void spfa(int s,int *dis)     //spfa
{
    queue<int>q;
    q.push(s);
    while(!q.empty())
    {
        int u=q.front();
        q.pop();
        book[u]=0;
        for(int i=head[u];i!=-1;i=e[i].next)
        {
            int v=e[i].v;
            if(dis[v]>dis[u]+e[i].w)
            {
                dis[v]=dis[u]+e[i].w;
                if(!book[v])
                {
                    book[v]=1;
                    q.push(v);
                }
            }
        }
    }
}
int main()
{
    while(cin>>n>>m)
    {
        t=0;
        memset(head,-1,sizeof(head));
        for(int i=0;i<m;i++){
            int t1,t2,t3;
            cin>>t1>>t2>>t3;
            add(t1,t2,t3);
            add(t2,t1,t3);
        }

        for(int i=1;i<=n;i++)  //从 1 到 n
            dis[i]=INF;
        dis[1]=0;
        memset(book,0,sizeof(book));
        spfa(1,dis);

        for(int i=1;i<=n;i++)  //从 n 到 1
            dis1[i]=INF;
        dis1[n]=0;
        memset(book,0,sizeof(book));
        spfa(n,dis1);

        int minn=INF;
        for(int i=0;i<t;i++){
            int x=e[i].u;
            int y=e[i].v;
            int ans=dis[x]+dis1[y]+e[i].w;
            if(ans==dis[n])              //去掉最短
                continue;
            minn=min(minn,ans);
        }
        cout<<minn<<endl;
    }
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值