4.1 根据后序和中序遍历输出先序遍历 (25分)

根据后序和中序遍历输出先序遍历

本题要求根据给定的一棵二叉树的后序遍历和中序遍历结果,输出该树的先序遍历结果。

输入格式:
第一行给出正整数N(≤30),是树中结点的个数。随后两行,每行给出N个整数,分别对应后序遍历和中序遍历结果,数字间以空格分隔。题目保证输入正确对应一棵二叉树。

输出格式:
在一行中输出Preorder:以及该树的先序遍历结果。数字间有1个空格,行末不得有多余空格。

输入样例:
7
2 3 1 5 7 6 4
1 2 3 4 5 6 7

输出样例:
Preorder: 4 1 3 2 6 5 7

代码:

#include <algorithm>
#include <iostream>
#include<string.h>
#include<stdio.h>
#include <stack>
#include <map>

using namespace std;

int s1[40], s2[40];

struct node {
	int data;
	struct node *lchild, *rchild;
};

node* fun(int n1, int n2, int m1, int m2) {
	node *head = new node();
	head->data = s1[n2];
	head->lchild = NULL;
	head->rchild = NULL;

	int i;
	for (i = m1; i <= m2; i++) {
		if (s2[i] == s1[n2]) {
			if (i != m1) {
				head->lchild = fun(n1, n1 + i - m1 - 1, m1, i - 1);
			}
			if (i != m2) {
				head->rchild = fun(n2 - m2 + i, n2 - 1, i + 1, m2);
			}
		}
	}

	return head;
}

void putout(node *now) {
	if (now == NULL) {
		return;
	}
	cout << " " << (*now).data;
	putout(now->lchild);
	putout(now->rchild);
}
int main() {

	int n;
	cin >> n;
	
	int i;
	for (i = 0; i < n; i++) {
		cin >> s1[i];
	}

	for (i = 0; i < n; i++) {
		cin >> s2[i];
	}

	node *head;
	head = fun(0, n - 1, 0, n - 1);
	cout << "Preorder:";
	putout(head);
	cout << endl;

	return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Vcatory

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值