HDU 1698 Just a Hook 线段树 附带详细说明 java实现

Just a Hook
Problem Description
In the game of DotA, Pudge’s meat hook is actually the most horrible thing for most of the heroes. The hook is made up of several consecutive metallic sticks which are of the same length.
Now Pudge wants to do some operations on the hook.
Let us number the consecutive metallic sticks of the hook from 1 to N. For each operation, Pudge can change the consecutive metallic sticks, numbered from X to Y, into cupreous sticks, silver sticks or golden sticks.
The total value of the hook is calculated as the sum of values of N metallic sticks. More precisely, the value for each kind of stick is calculated as follows:
For each cupreous stick, the value is 1.
For each silver stick, the value is 2.
For each golden stick, the value is 3.
Pudge wants to know the total value of the hook after performing the operations.
You may consider the original hook is made up of cupreous sticks.
Input
The input consists of several test cases. The first line of the input is the number of the cases. There are no more than 10 cases.
For each case, the first line contains an integer N, 1<=N<=100,000, which is the number of the sticks of Pudge’s meat hook and the second line contains an integer Q, 0<=Q<=100,000, which is the number of the operations.
Next Q lines, each line contains three integers X, Y, 1<=X<=Y<=N, Z, 1<=Z<=3, which defines an operation: change the sticks numbered from X to Y into the metal kind Z, where Z=1 represents the cupreous kind, Z=2 represents the silver kind and Z=3 represents the golden kind.
Output
For each case, print a number in a line representing the total value of the hook after the operations. Use the format in the example.
Sample Input
1
10
2
1 5 2
5 9 3
Sample Output
Case 1: The total value of the hook is 24.

题意大概意思 有三种物品,每种物品价值为1,2,3.
初始n个物品的价值都为1.
q个查询,每次把区间(l,r)的物品替换成x.
q次查询后输出n个物品的总价值。
涉及区间替换,区间求和。
sum数组维护区间的和,利用延迟(懒惰)标记可以减少递归的深度。
每次要用到某个区间的时候才把该区间替换。

public class Main {

    public static int[] sum;
    public static int[] lazy;
    public static void pushUp(int rt){
        sum[rt]=sum[rt<<1]+sum[rt<<1|1];  //向上更新父亲节点的区间和
    }
    public static void pushDown(int rt,int d){  //向下更新孩子节点的区间和
        if(lazy[rt]!=0){
            lazy[rt<<1]=lazy[rt]; //懒惰标记转移到孩子节点
            lazy[rt<<1|1]=lazy[rt];
            sum[rt<<1|1]=(d>>1)*lazy[rt];  //孩子节点区间和更新
            sum[rt<<1]=(d-(d>>1))*lazy[rt]; 
            lazy[rt]=0;  //将父亲节点的懒惰标记去除
        }
    }
    public static void build(int l,int r,int rt){
        if(l==r){
            sum[rt]=1;  //初始值为1
            return;
        }
        int mid=(l+r)>>1;
        build(l,mid,rt<<1); 
        build(mid+1,r,rt<<1|1);
        pushUp(rt);
    }

    public static void update(int L,int R,int c,int l,int r,int rt){
        if(L<=l&&r<=R){  //在区间内
            lazy[rt]=c;  //加持懒惰标记
            sum[rt]=(r-l+1)*c; //更新区间和
            return;
        }
        pushDown(rt,r-l+1);  //向下更新 需要用到懒惰标记
        int mid=(l+r)>>1;
        if(L<=mid){  
            update(L,R,c,l,mid,rt<<1);
        }
        if(R>mid){
            update(L,R,c,mid+1,r,rt<<1|1);
        }
        pushUp(rt);  //最后还是需要更新一下父亲节点的区间和
    }

    public static void main(String[] args) {
        Scanner cin=new Scanner(System.in);
        int Case=cin.nextInt();
        for(int i=1;i<=Case;++i){
            int n=cin.nextInt();
            sum=new int[n<<2];
            lazy=new int[n<<2];
            build(1,n,1);
            int q=cin.nextInt();
            for(int j=1;j<=q;++j){
                int a=cin.nextInt();
                int b=cin.nextInt();
                int c=cin.nextInt();
                update(a,b,c,1,n,1);
            }
            System.out.println("Case "+i+": The total value of the hook is "+sum[1]+".");
        }
    }
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值