hdu 2084 数塔

78 篇文章 1 订阅
23 篇文章 0 订阅

关键字:动态规划

题目:
Input
输入数据首先包括一个整数C,表示测试实例的个数,每个测试实例的第一行是一个整数N(1 <= N <= 100),表示数塔的高度,接下来用N行数字表示数塔,其中第i行有个i个整数,且所有的整数均在区间[0,99]内。

Output
对于每个测试实例,输出可能得到的最大和,每个实例的输出占一行。

Sample Input
1
5
7
3 8
8 1 0
2 7 4 4
4 5 2 6 5

Sample Output
30

链接:
http://acm.hdu.edu.cn/showproblem.php?pid=2084

代码:

#include <iostream>
#include <cmath>
#include <cstring>
using namespace std;
const int maxn = 110;
int a[maxn][maxn];

int main(){
//    freopen("a.txt", "r", stdin);
    int k, n;
    while(cin >> k){
        while(k--){
            cin >> n;
            memset(a, 0, sizeof(a));
            for(int i = 1; i <= n; ++i){
                for(int j = 1; j <= i; ++j){
                    cin >> a[i][j];
                }
            }
            for(int i = n - 1; i >= 1; --i){
                for(int j = 1; j <= i; ++j){
                    a[i][j] = a[i][j] + max(a[i + 1][j], a[i + 1][j + 1]);
                }
            }
            cout << a[1][1] << endl;
        }
    }
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值