poj 1742 Coins(多重背包)

52 篇文章 0 订阅
18 篇文章 0 订阅
Coins
Time Limit: 3000MS Memory Limit: 30000K
Total Submissions: 25171 Accepted: 8514

Description

People in Silverland use coins.They have coins of value A1,A2,A3...An Silverland dollar.One day Tony opened his money-box and found there were some coins.He decided to buy a very nice watch in a nearby shop. He wanted to pay the exact price(without change) and he known the price would not more than m.But he didn't know the exact price of the watch.
You are to write a program which reads n,m,A1,A2,A3...An and C1,C2,C3...Cn corresponding to the number of Tony's coins of value A1,A2,A3...An then calculate how many prices(form 1 to m) Tony can pay use these coins.

Input

The input contains several test cases. The first line of each test case contains two integers n(1<=n<=100),m(m<=100000).The second line contains 2n integers, denoting A1,A2,A3...An,C1,C2,C3...Cn (1<=Ai<=100000,1<=Ci<=1000). The last test case is followed by two zeros.

Output

For each test case output the answer on a single line.

Sample Input

3 10
1 2 4 2 1 1
2 5
1 4 2 1
0 0

Sample Output

8
4
题意:有n种不同面值的硬币,每种硬币有数量若干个,求用这些硬币可以组成的不超过m的面值的种数。
思路:多重背包。如果用二进制优化,会TLE。这里的做法是把多重背包转化为完全背包,但是数量有限制,所以开一个数组记录到达j时所用的硬币的次数。
 
AC代码:
#include <cstring>
#include <string>
#include <cstdio>
#include <algorithm>
#include <queue>
#include <cmath>
#include <vector>
#include <cstdlib>
#include <iostream>

using namespace std;

int n,m;
int a[105],c[105];
bool dp[100005];
int q[100005];     //记录硬币所用次数
int main()
{
    while(scanf("%d%d",&n,&m),n||m)
    {
        for(int i=0; i<n; i++)
            scanf("%d",&a[i]);
        for(int i=0; i<n; i++)
            scanf("%d",&c[i]);
        memset(dp,false,sizeof(dp));
        dp[0]=true;
        for(int i=0; i<n; i++)
        {
            memset(q,0,sizeof(q));
            for(int j=a[i]; j<=m; j++)
                if(!dp[j])
                {
                    if(dp[j-a[i]]&&q[j-a[i]]<c[i])
                    {
                        dp[j]=true;
                        q[j]=q[j-a[i]]+1;
                    }
                }
        }
        int cnt=0;
        for(int i=1; i<=m; i++)
            if(dp[i])
            {
                cnt++;
            }
        printf("%d\n",cnt);
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值