HDU 2647 Reward

Reward

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 10379 Accepted Submission(s): 3319

Problem Description

Dandelion’s uncle is a boss of a factory. As the spring festival is coming , he wants to distribute rewards to his workers. Now he has a trouble about how to distribute the rewards.
The workers will compare their rewards ,and some one may have demands of the distributing of rewards ,just like a’s reward should more than b’s.Dandelion’s unclue wants to fulfill all the demands, of course ,he wants to use the least money.Every work’s reward will be at least 888 , because it’s a lucky number.

Input

One line with two integers n and m ,stands for the number of works and the number of demands .(n<=10000,m<=20000)
then m lines ,each line contains two integers a and b ,stands for a’s reward should be more than b’s.

Output

For every case ,print the least money dandelion ‘s uncle needs to distribute .If it’s impossible to fulfill all the works’ demands ,print -1.

Sample Input

2 1
1 2
2 2
1 2
2 1

Sample Output

1777
-1

Author

dandelion

Source

曾是惊鸿照影来

Recommend

yifenfei | We have carefully selected several similar problems for you: 1285 3342 2112 2094 1874

题意

​ n个人,m个关系。例如a b,意思是a要比b拿的钱多(其实多一块钱就行了)。问最少需要多少钱。如果存在环,就输出-1。

解题思路

​ 很容易想到拓扑排序。这里我加了个等级数组,每次在节点入队的时候就可以初始化其对应的等级,拓扑排序结束后先判断是否存在环,若不存在直接求出等级和就行了。

代码

#include<stdio.h>
#include<iostream>
#include<vector>
#include<queue>
#include<string.h>
using namespace std;
#define maxn 10005
#define inf 0x3f3f3f3f

int in[maxn],lev[maxn];
vector<int> v[maxn];

int main()
{
    //freopen("in.txt","r",stdin);
    int n,m;
    while(~scanf("%d%d",&n,&m))
    {
        int a,b;
        memset(in,0,sizeof(in));
        memset(lev,0,sizeof(lev));
        for(int i=1; i<=n; i++)
            v[i].clear();
        for(int i=0; i<m; i++)
        {
            scanf("%d%d",&a,&b);
            v[b].push_back(a);   //
            in[a]++;
        }
        queue<int> q;
        for(int i=1; i<=n; i++)
            if(!in[i])
            {
                q.push(i);
                lev[i]=0;
            }
        while(!q.empty())
        {
            int x=q.front();
            q.pop();
            for(int i=0; i<v[x].size(); i++)
            {
                int y=v[x][i];
                in[y]--;
                if(!in[y])
                {
                    q.push(y);
                    lev[y]=lev[x]+1;
                }
            }
        }
        int flag=0;
        for(int i=1; i<=n; i++)
            if(in[i])
            {
                flag=1;
                break;
            }
        if(flag) puts("-1");
        else
        {
            long long sum=0;
            for(int i=1; i<=n; i++)
                sum+=lev[i];
            printf("%lld\n",sum+888*n);
        }
    }
    return 0;
}

转载于:https://www.cnblogs.com/RefrainLi/p/8861412.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值