HDU - 2647 Reward

Dandelion's uncle is a boss of a factory. As the spring festival is coming , he wants to distribute rewards to his workers. Now he has a trouble about how to distribute the rewards. 
The workers will compare their rewards ,and some one may have demands of the distributing of rewards ,just like a's reward should more than b's.Dandelion's unclue wants to fulfill all the demands, of course ,he wants to use the least money.Every work's reward will be at least 888 , because it's a lucky number.

 

Input

One line with two integers n and m ,stands for the number of works and the number of demands .(n<=10000,m<=20000) 
then m lines ,each line contains two integers a and b ,stands for a's reward should be more than b's.

 

Output

For every case ,print the least money dandelion 's uncle needs to distribute .If it's impossible to fulfill all the works' demands ,print -1.

 

Sample Input

2 1
1 2
2 2
1 2
2 1

Sample Output

1777
-1

 

题目大意:过年老板给员工发工资,最低没人888元,有的员工会有一些要求,输入n,m分别表示有n个员工,m个需求,接下来m行两个整数a,b,表示a的工资比b高,输出老板需要话工资的最少钱数,如果满足不了输出-1

解题思路:拓扑排序的变形,在拓扑排序的过程中确定每个人工资在888的基础上需要额外加多少钱,便于计算,建边的时候和输入相反,然后使用bfs来遍历边,这样深度加一则额外钱数需比上一层多加一,第一层不需要加钱,为0,这样在拓扑排序的过程中就可以计算需要加的额外钱数 

AC代码:

#include<iostream>
#include<cstring>
#include<queue>
#include<cstdio>
using namespace std;
const int maxn=1e6;

struct edge{
	int u;
	int to;
	int next;
}e[maxn];

int head[maxn],degree[maxn],extra[maxn],cnt;

void init()
{
	cnt=0;
	memset(head,-1,sizeof(head));
	memset(degree,0,sizeof(degree));
	memset(extra,0,sizeof(extra));
} 
void add(int u,int v)
{
	e[cnt].u=u;
	e[cnt].to=v;
	e[cnt].next=head[u];
	head[u]=cnt++;
} 

void toposort(int n)
{
	int ans=0;
	queue<int> term;
	for(int i=1;i<=n;i++)
	{
		if(!degree[i])
		{
			ans++;
			term.push(i);
		}
	}
	while(!term.empty())
	{
		int u=term.front();
		term.pop();
		for(int i=head[u];~i;i=e[i].next) 
		{
			int to=e[i].to;
			degree[to]--;
			if(!degree[to])
			{
				ans++;
				term.push(to);
				extra[to]=extra[u]+1;
			}
		}
	}
	if(ans==n)
	{
		int sum=0;
		for(int i=1;i<=n;i++)
		{
			sum+=extra[i]+888;
		}
		cout<<sum<<endl;
	}
	else
		cout<<"-1"<<endl;
}
int main()
{
	int m,n,x,y;
	while(cin>>n>>m)
	{
		init();
		for(int i=0;i<m;i++)
		{
			cin>>x>>y;
			add(y,x);
			degree[x]++;
		} 
		toposort(n);
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值