Volume 0. Getting Started 490 - Rotating Sentences


Rotating Sentences

In ``Rotating Sentences,'' you are asked to rotate a series of input sentences 90 degrees clockwise. So instead of displaying the input sentences from left to right and top to bottom, your program will display them from top to bottom and right to left.

Input and Output

As input to your program, you will be given a maximum of 100 sentences, each not exceeding 100 characters long. Legal characters include: newline, space, any punctuation characters, digits, and lower case or upper case English letters. (NOTE: Tabs are not legal characters.)

The output of the program should have the last sentence printed out vertically in the leftmost column; the first sentence of the input would subsequently end up at the rightmost column.

Sample Input

Rene Decartes once said,
"I think, therefore I am."

Sample Output

"R
Ie
 n
te
h 
iD
ne
kc
,a
 r
tt
he
es
r
eo
fn
oc
re
e
 s
Ia
 i
ad
m,
.
"

题目大意:你的程序要读入最多100个句子,每个句子不超过100个字符。输出是:每一列输出一个句子,第一个读入的句子放在最后一列,最后一个读入的句子放在第一列。

 

MySubmit:


 

#include<cstdio>
#include<cstring>
int main(){
    char ch[110][110];
    memset(ch,0,sizeof(ch));
    int i=0,j,k,len,max_len=0;
    while(fgets(ch[i],110,stdin)!=NULL){
        len=strlen(ch[i]);
        ch[i][--len]=' ';//因为 fgets() 会把 '\n' 也读到字符串数组里。
        if(len>max_len) max_len=len;
        ++i;
    }
    for(k=0;k<max_len;++k){
        for(j=i-1;j>=0;--j){
            if(ch[j][k]) printf("%c",ch[j][k]);
            else printf(" ");
        }
        printf("\n");
    }
    return 0;
}


 


 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值