题目描述
输入样例1
5
1 2 0
2 4 3
3 0 0
4 0 5
5 0 0
输出样例1
3
4 5
输出样例2
5
2 5 3
1 2 0
3 0 0
4 0 0
5 0 4
输出样例2
3
4 5
思路
dfs + 二叉树
存储结构
1.用结构体数组存储每个节点的父节点、左右节点
2.用vector存储答案
具体做法
1.根据输出,构建家谱
2.遍历每一个点,找出父节点==0的点,该点为祖宗节点
3.从祖宗节点开始dfs
①当辈分 大于 上一次递归辈分时,说明找到了更小辈分的,将res清空,并将当前辈分最小的加入res
②当辈分 等于 上一次递归辈分时,将该节点加入res数组
4.如果该点的左节点存在(子节点),继续遍历,辈分+1
5.如果该点的右节点存在(兄弟节点),继续遍历,辈分不变
AC代码
#include <bits/stdc++.h>
using namespace std;
const int N = 100010;
vector<int> res;
typedef struct
{
int fa, son, bro;
}person;
person p[N];
int cnt = -1;
void dfs(int x, int step)
{
if(step > cnt)
{
cnt = step;
res.clear();
res.push_back(x);
}
else if(step == cnt) res.push_back(x);
if(p[x].son) dfs(p[x].son, step + 1); //搜索子节点,辈分+1
if(p[x].bro) dfs(p[x].bro, step); //搜索兄弟节点,辈分不变
}
int main()
{
int n;
scanf("%d", &n);
for(int i = 0; i < n; i ++)
{
int a, b, c;
scanf("%d%d%d", &a, &b, &c);
if(b)
{
p[a].son = b;
p[b].fa = a;
}
if(c)
{
p[a].bro = c;
p[c].fa = a; //这里的意思不是c的父亲是a,只是在树的关系中,c是a的一个节点,这会影响到下面找祖宗节点
}
}
int root;
for(int i = 1; i <= n; i ++)
{
if(!p[i].fa)
{
root = i;
break;
}
}
//printf("%d\n", root);
dfs(root, 1);
printf("%d\n", cnt);
sort(res.begin(), res.end());
for(int i = 0; i < res.size(); i ++)
{
if(i != res.size() - 1) printf("%d ", res[i]);
else printf("%d\n", res[i]);
}
return 0;
}
总结
相较于小字辈,该题多了一步对兄弟节点的遍历
欢迎大家批评指正!!!