1154 Vertex Coloring (25 分)

proper vertex coloring is a labeling of the graph's vertices with colors such that no two vertices sharing the same edge have the same color. A coloring using at most k colors is called a (proper) k-coloring.

Now you are supposed to tell if a given coloring is a proper k-coloring.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N and M (both no more than 10​4​​), being the total numbers of vertices and edges, respectively. Then M lines follow, each describes an edge by giving the indices (from 0 to N−1) of the two ends of the edge.

After the graph, a positive integer K (≤ 100) is given, which is the number of colorings you are supposed to check. Then K lines follow, each contains Ncolors which are represented by non-negative integers in the range of int. The i-th color is the color of the i-th vertex.

Output Specification:

For each coloring, print in a line k-coloring if it is a proper k-coloring for some positive k, or No if not.

Sample Input:

10 11
8 7
6 8
4 5
8 4
8 1
1 2
1 4
9 8
9 1
1 0
2 4
4
0 1 0 1 4 1 0 1 3 0
0 1 0 1 4 1 0 1 0 0
8 1 0 1 4 1 0 5 3 0
1 2 3 4 5 6 7 8 8 9

Sample Output:

4-coloring
No
6-coloring
No

大意:

给出一个图,然后输入给这个图的所有点上色的几种case,找出哪个case能使图中连接在同一条边上两个点的颜色不同

#include<iostream>
#include<vector>
#include<set>
using namespace std;
struct edges{     //边集
	int v1,v2;    //边的邻接点
};
int main(){
	int n,m,k;    //点数、边数、要判断是不是k-coloring的case数目
	cin>>n>>m;
	edges edge[m];
	vector<int> v(n);     //存一条case对图中每个点的上色情况
	for(int i=0;i<m;i++)
		cin>>edge[i].v1>>edge[i].v2;
	cin>>k;
	while(k--){
		int flag=1;
		set<int> color;    //记录输入的颜色的数目 
		for(int i=0;i<n;i++){
			cin>>v[i];
			color.insert(v[i]);
		}
		for(int i=0;i<m;i++){
		// 对每条边的两个端点进行遍历,如果两个点颜色相同,则不是 k-coloring 图 
			if(v[edge[i].v1]==v[edge[i].v2]){
				flag=0;
				break; 
			}
		}
		if(flag) printf("%d-coloring\n",color.size());
		else printf("No\n");
	}
	return 0;
} 

 题目是英语的确有点烦人

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值