HDOJ 1102

Constructing Roads

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 14768    Accepted Submission(s): 5613


Problem Description
There are N villages, which are numbered from 1 to N, and you should build some roads such that every two villages can connect to each other. We say two village A and B are connected, if and only if there is a road between A and B, or there exists a village C such that there is a road between A and C, and C and B are connected.

We know that there are already some roads between some villages and your job is the build some roads such that all the villages are connect and the length of all the roads built is minimum.
 

Input
The first line is an integer N (3 <= N <= 100), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 1000]) between village i and village j.

Then there is an integer Q (0 <= Q <= N * (N + 1) / 2). Then come Q lines, each line contains two integers a and b (1 <= a < b <= N), which means the road between village a and village b has been built.
 

Output
You should output a line contains an integer, which is the length of all the roads to be built such that all the villages are connected, and this value is minimum.
 

Sample Input
  
  
3 0 990 692 990 0 179 692 179 0 1 1 2
 

Sample Output
  
  
179
题目的大概意思是输入每个村庄与其他村庄的距离以及已经存在的村庄之间的路,要求求出最小的总路线和,使得村庄之间全部连通(已经存在路不算在其中)。刚开始的时候我还在想能不能用最短路径的方法分别先求出每个村庄到其他村庄之间的最短路径,然后再加起来。结果发现行不通,只能用生成最小生成树的方法,本题我选择kruskal算法,求出最小路径和。
以下是代码:
#include <iostream>
#include <string.h>
#include <cstring>
#include <string>
#include <algorithm>
#include <stack>
#include <queue>
#include <stdio.h>
#include <stdlib.h>
#include <cstdlib>
#include <cmath>
#include <math.h>
#include <vector>
#include <map>
#include <time.h>
#include <ctime>
#define M 1200
using namespace std;
int a[M];
typedef struct {
    int x;
    int y;
    int num;
}Node;
vector <Node> b;
int find(int x)
{
    while(x!=a[x])
        x=a[x];
    return x;
}
int kruscal(int x)
{
    int v1,v2;
    int count=0;
    int min,minj,mini, j;
    for(int t=0;t < b.size();t++)
    {
        mini = b[t].x;
        minj = b[t].y;
        min = b[t].num;
        v1=find(mini);
        v2=find(minj);
        if(v1!=v2)
        {
            a[v1]=v2;
            j++;
            count+=min;
        }
        if(j == x-1)
            break;
    }
    return count;
}
void merge(int x,int y)
{
    int h,b;
    h=find(x);
    b=find(y);
    if(h!=b)
        a[h]=b;
}
int cmp(Node x, Node y)
{
    int num1, num2;
    num1 = x.num;
    num2 = y.num;
    return num1 < num2;
}
int main()
{
    int i,j,n,q,sum,min,x,y;
    Node node;
    while(cin>>n)
    {
        memset(a,0,sizeof(a));
        b.clear();
        for(i=1;i<M;i++)
            a[i]=i;
        for(i=1;i<=n;i++)
        {
            for(j=1;j<=n;j++)
            {
                cin >> node.num;
                node.x = i;
                node.y = j;
                b.push_back(node);
            }
        }
        sort(b.begin(),b.end(),cmp);
        cin>>q;
        for(i=1;i<=q;i++)
        {
            cin>>x>>y;
            merge(x,y);
        }
        sum=kruscal(n);
        cout<<sum<<endl;
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值