1241 Oil Deposits

Oil Deposits

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 15592    Accepted Submission(s): 8943


Problem Description
The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid. 
 

Input
The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket.
 

Output
For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.
 

Sample Input
       
       
1 1 * 3 5 *@*@* **@** *@*@* 1 8 @@****@* 5 5 ****@ *@@*@ *@**@ @@@*@ @@**@ 0 0
 

Sample Output
       
       
0 1 2 2
水题。。。。但是没有看清楚题目的意思,刚开始以为是4个方向,结果是8个方向,然后脑残的用set来存,会有出现两个不一样的油田但是油数量一样的情况,因此WA了,最后还是老老实实用填充的方法,遇到一个'@'就遍历填充,sum++,直到全部遍历

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <string>
#include <vector>
#include <algorithm>
#include <stdlib.h>
#include <set>
using namespace std;
#define M 105
char map[M][M];
int n, m;
set <int> se;
int dir[][2] = {1,0,-1,0,0,1,0,-1,1,1,1,-1,-1,-1,-1,1};
int sum;
void DFS(int x, int y){
 int num1, num2;
 for(int i = 0; i < 8; i++){
  num1 = x + dir[i][0];
  num2 = y + dir[i][1];
  if(map[num1][num2] == '@'){
   map[num1][num2] = '*';
   DFS(num1,num2);
  }
 }
}
int main(){
 while(scanf("%d%d",&n,&m)!=EOF){
  if(n == 0 && m == 0)
   break;
  memset(map,0,sizeof(map));
  for(int i = 0; i < n; i++){
   scanf("%s",&map[i]);
  }
  sum = 0;
  for(int i = 0; i < n; i++){
   for(int j = 0; j < m; j++){
    if(map[i][j] == '@'){
     map[i][j] = '*';
     DFS(i,j);
     sum ++;
    }
   }
  }
  printf("%d\n",sum);
  se.clear();
 }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值