HDU - 2612(两次BFS)

题目链接:HDU 2612

题目:

Pass a year learning in Hangzhou, yifenfei arrival hometown Ningbo at finally. Leave Ningbo one year, yifenfei have many people to meet. Especially a good friend Merceki. 
Yifenfei’s home is at the countryside, but Merceki’s home is in the center of city. So yifenfei made arrangements with Merceki to meet at a KFC. There are many KFC in Ningbo, they want to choose one that let the total time to it be most smallest. 
Now give you a Ningbo map, Both yifenfei and Merceki can move up, down ,left, right to the adjacent road by cost 11 minutes. 

Input

The input contains multiple test cases. 
Each test case include, first two integers n, m. (2<=n,m<=200). 
Next n lines, each line included m character. 
‘Y’ express yifenfei initial position. 
‘M’    express Merceki initial position. 
‘#’ forbid road; 
‘.’ Road. 
‘@’ KCF 

Output

For each test case output the minimum total time that both yifenfei and Merceki to arrival one of KFC.You may sure there is always have a KFC that can let them meet.

Sample Input

4 4
Y.#@
....
.#..
@..M
4 4
Y.#@
....
.#..
@#.M
5 5
Y..@.
.#...
.#...
@..M.
#...#

Sample Output

66
88
66

题目思路 :

不能在每个@处都进行两次BFS  这样太耗时间了 

用两次BFS 每次路过@ 都用一个数组保存它的步数  最后在找一遍最小值就可以了 

这里走一格是11分钟

AC代码:

#include <cstdio>
#include <cstring>
#include <queue>
#include <iostream>
#include <math.h>
using namespace std;
const int maxn = 0x3f3f3f3f;
int dx[4]= {0,0,1,-1};
int dy[4]= {1,-1,0,0};
char pic[205][205];
int vis[205][205],n,m,minn,byx,byy,bmx,bmy,ty,tm,step[205][205];
struct node
{
    int x,y,step;
};
void bfs1()
{
    memset(vis,0,sizeof(vis));
    node b,now,next;
    b.x=byx;
    b.y=byy;
    b.step=0;
    vis[b.x][b.y]=1;
    queue <node> q;
    while(!q.empty())q.pop();
    q.push(b);
    while(!q.empty())
    {
        now = q.front();
        q.pop();
        if(pic[now.x][now.y]=='@' && vis[now.x][now.y]==0)
                step[now.x][now.y]=now.step;
        for(int d=0 ; d<4 ; d++)
        {
            next = now;
            next.x += dx[d];
            next.y += dy[d];
            next.step++;
            if(next.x<0 || next.y<0 || next.x>=n || next.y>=m)continue;
            else if(pic[next.x][next.y]=='#' || vis[next.x][next.y]==1 )continue;
            else if(pic[next.x][next.y]=='@' && vis[next.x][next.y]==0)
            {
                step[next.x][next.y]=next.step;
                vis[next.x][next.y]=1;
                q.push(next);
            }
            else
            {
                vis[next.x][next.y]=1;
                q.push(next);
            }
        }
    }
    return ;
}
void bfs2()
{
    memset(vis,0,sizeof(vis));
    node b,now,next;
    b.x=bmx;
    b.y=bmy;
    b.step=0;
    vis[b.x][b.y]=1;
    queue <node> q;
    while(!q.empty())q.pop();
    q.push(b);
    while(!q.empty())
    {
        now = q.front();
        q.pop();
        if(pic[now.x][now.y]=='@' && vis[now.x][now.y]==0)
                step[now.x][now.y] += now.step;
        for(int d=0 ; d<4 ; d++)
        {
            next = now;
            next.x += dx[d];
            next.y += dy[d];
            next.step++;
            if(next.x<0 || next.y<0 || next.x>=n || next.y>=m)continue;
            else if(pic[next.x][next.y]=='#' || vis[next.x][next.y]==1 )continue;
            else if(pic[next.x][next.y]=='@' && vis[next.x][next.y]==0)
            {
                step[next.x][next.y] += next.step;
                vis[next.x][next.y]=1;
                q.push(next);
            }
            else
            {
                vis[next.x][next.y]=1;
                q.push(next);
            }
        }
    }
    return ;
}
int main()
{
//    freopen("in.txt","r",stdin);
    while(scanf("%d %d",&n,&m)!=EOF)
    {
        getchar();
        for(int i=0; i<n; i++)
        {
            for(int j=0; j<m; j++)
            {
                scanf("%c",&pic[i][j]);
                if(pic[i][j]=='Y'){byx=i; byy=j;}
                if(pic[i][j]=='M'){bmx=i; bmy=j;}
            }
            getchar();
        }
        memset(step,0,sizeof(step));
        bfs1();
        bfs2();
        minn = maxn;
        for(int i=0;i<n;i++)
        {
            for(int j=0;j<m;j++)
                if(step[i][j]!=0)
                minn = min(minn , step[i][j]);
        }
        printf("%d\n",11*minn);

    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值