bfs入门?巨坑 hdu2717

                                  Catch That Cow

Time Limit: 5000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 20083    Accepted Submission(s): 5886


 

Problem Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

 Input

Line 1: Two space-separated integers: N and K

 Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

 Sample Input

5 17

 Sample Output

4 

很简单的bfs我却一直re;想了好久,重写了个check函数,交上去过了,发现每次判断的顺序有问题,应该先判断是否在范围里,再去判断是否走重;因为对于超出范围的点要剪掉的比走重的肯定多;

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
#include<queue>
#include<set>
#include<cmath>
#define sqr(x) ((x) * (x))
using namespace std;
const int MOD=999997;
const int INF=0x3f3f3f3f;
const int maxn=1e6+5;
struct node
{
    int x;
    int st;
};
int vis[maxn];
int n,k;
node hh;
int xx;
inline bool check(int x)
{
    if(x>=0&&x<1000000&&!vis[x]) return true;
    return false;
}
void bfs()
{
    queue<node> q;
    memset(vis,0,sizeof vis);
    node t,f;
    t.x=n;
    t.st=0;
    q.push(t);
    vis[n]=1;
    while(!q.empty())
    {
        f=q.front();
        q.pop();
        if(f.x==k)
        {
            cout<<f.st<<endl;
            return ;
        }
        hh.st=f.st+1;
        xx=f.x+1;
        if(check(xx))
        {
            vis[xx]=1;
            hh.x=xx;
            q.push(hh);
        }
        xx=f.x-1;
        if(check(xx))
        {
            vis[xx]=1;
            hh.x=xx;

            q.push(hh);
        }
        xx=f.x*2;
        if(check(xx))
        {
            vis[xx]=1;
            hh.x=xx;

            q.push(hh);
        }
    }
    cout<<-1<<endl;
    return;
}
int main()
{
    while(~scanf("%d%d",&n,&k))
    {
        bfs();
    }

}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值