2018-焦作网络赛 Mathematical Curse (dp)细节比较多

A prince of the Science Continent was imprisoned in a castle because of his contempt for mathematics when he was young, and was entangled in some mathematical curses. He studied hard until he reached adulthood and decided to use his knowledge to escape the castle.

There are NNN rooms from the place where he was imprisoned to the exit of the castle. In the ithi^{th}ith room, there is a wizard who has a resentment value of a[i]a[i]a[i]. The prince has MMM curses, the jthj^{th}jth curse is f[j]f[j]f[j], and f[j]f[j]f[j] represents one of the four arithmetic operations, namely addition('+'), subtraction('-'), multiplication('*'), and integer division('/'). The prince's initial resentment value is KKK. Entering a room and fighting with the wizard will eliminate a curse, but the prince's resentment value will become the result of the arithmetic operation f[j]f[j]f[j] with the wizard's resentment value. That is, if the prince eliminates the jthj^{th}jth curse in the ithi^{th}ith room, then his resentment value will change from xxx to (x f[j] a[i]x\ f[j]\ a[i]x f[j] a[i]), for example, when x=1,a[i]=2,f[j]=x=1, a[i]=2, f[j]=x=1,a[i]=2,f[j]='+', then xxx will become 1+2=31+2=31+2=3.

Before the prince escapes from the castle, he must eliminate all the curses. He must go from a[1]a[1]a[1] to a[N]a[N]a[N] in order and cannot turn back. He must also eliminate the f[1]f[1]f[1] to f[M]f[M]f[M] curses in order(It is guaranteed that N≥MN\ge MN≥M). What is the maximum resentment value that the prince may have when he leaves the castle?

Input

The first line contains an integer T(1≤T≤1000)T(1 \le T \le 1000)T(1≤T≤1000), which is the number of test cases.

For each test case, the first line contains three non-zero integers: N(1≤N≤1000),M(1≤M≤5)N(1 \le N \le 1000), M(1 \le M \le 5)N(1≤N≤1000),M(1≤M≤5) and K(−1000≤K≤1000K(-1000 \le K \le 1000K(−1000≤K≤1000), the second line contains NNN non-zero integers: a[1],a[2],...,a[N](−1000≤a[i]≤1000)a[1], a[2], ..., a[N](-1000 \le a[i] \le 1000)a[1],a[2],...,a[N](−1000≤a[i]≤1000), and the third line contains MMM characters: f[1],f[2],...,f[M](f[j]=f[1], f[2], ..., f[M](f[j] =f[1],f[2],...,f[M](f[j]='+','-','*','/', with no spaces in between.

Output

For each test case, output one line containing a single integer.

样例输入

3
2 1 5
2 3
/
3 2 1
1 2 3
++
4 4 5
1 2 3 4
+-*/

样例输出

2
6
3
​


#include<cstring>
#include<cstdio>
#include<string>
#include<iomanip>
#include<algorithm>
#include<vector>
#include<cmath>
#define INF 0x3f3f3f3f
typedef long long LL;
using namespace std;

int a[1010];
char f[10];
//dp所存储的是前n个数用来前n个符号时可以取的最大值
LL dp1[1010][10];//存最大值
LL dp2[1010][10];//存最小值

LL op(LL a,LL b,char c)
{
	if(c=='+') return a+b;
	if(c=='-') return a-b;
	if(c=='/') return a/b;
	else if (c=='*') return a*b;
}

int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
		{
            int n,m,k;
            LL maxx,minn,ans;
			scanf("%d%d%d",&n,&m,&k);
			for(int i=1;i<=n;i++)
			{
				scanf("%d",&a[i]);
				dp1[i][0]=k;
				dp2[i][0]=k;
			}
			scanf("%s",f+1);
			dp1[0][0]=k;
			dp2[0][0]=k;
            //已经做了的预处理
	        for(int i=1;i<=n;i++)
	        {
                for(int j=1;j<=min(m,i);j++)//不能写出for j=i j<=i j++
	            {
                //特别注意向上更新的条件因为
					LL tmp1=dp1[i-1][j-1],tmp2=dp2[i-1][j-1];
					maxx=max(op(tmp1,a[i],f[j]),op(tmp2,a[i],f[j]));
					minn=min(op(tmp1,a[i],f[j]),op(tmp2,a[i],f[j]));
                    dp1[i][j]=max(dp1[i-1][j],maxx);
                    dp2[i][j]=min(dp2[i-1][j],minn);
                    if(i==j)
                    {
                        dp1[i][j]=maxx;
                        dp2[i][j]=minn;
                    }
	            }
	        }
	        printf("%lld\n",dp1[n][m]);
	    }
    return 0;
}


[点击并拖拽以移动]
​

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值