【玲珑杯 1010 Alarm】

Alarm
DESCRIPTION
Given a number sequence
[
3
,
7
,
22
,
45
,
116
,
.
.
.
]
[3,7,22,45,116,…]. Please tell me the
k
k-th number.
INPUT
A number
T

(
T
<
100
)
T (T<100) indicates the number of the input cases. Then for each case there only is one integer
k

(
1

k

10000
)
k (1≤k≤10000).
OUTPUT
For each case, ouput the
k
k-th number of the sequence in one line.
SAMPLE INPUT
2
1
4
SAMPLE OUTPUT
3
45

#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
#include<queue>
#define K 1000011
#define INF  0x3f3f3f
using namespace std;
long long  a[K]={1,1};
long long  st[K];
long long ans;
int main()
{
    int l,i,j,N,t=1;
    for(i=2;i<1000;i++)
    {
        if(!a[i])
        {
            for(j=i*i;j<K;j+=i)
            a[j]=1;
        }
    }
    for(i=2;i<1100000;i++)
    {
        if(!a[i])
        st[t++]=i;
    }
    scanf("%d",&N);
    while(N--)
    {
        scanf("%d",&l);
        ans=st[l]*st[l]-l;
        printf("%lld\n",ans);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值