【HDU 5908 Abelian Period】

Abelian Period

Problem Description
Let S be a number string, and occ(S,x) means the times that number x occurs in S.

i.e. S=(1,2,2,1,3),occ(S,1)=2,occ(S,2)=2,occ(S,3)=1.

String u,w are matched if for each number i, occ(u,i)=occ(w,i) always holds.

i.e. (1,2,2,1,3)≈(1,3,2,1,2).

Let S be a string. An integer k is a full Abelian period of S if S can be partitioned into several continous substrings of length k, and all of these substrings are matched with each other.

Now given a string S, please find all of the numbers k that k is a full Abelian period of S.

Input
The first line of the input contains an integer T(1≤T≤10), denoting the number of test cases.

In each test case, the first line of the input contains an integer n(n≤100000), denoting the length of the string.

The second line of the input contains n integers S1,S2,S3,…,Sn(1≤Si≤n), denoting the elements of the string.

Output
For each test case, print a line with several integers, denoting all of the number k. You should print them in increasing order.

Sample Input
2
6
5 4 4 4 5 4
8
6 5 6 5 6 5 5 6

Sample Output
3 6
2 4 8

Source
BestCoder Round #88

Recommend
wange2014 | We have carefully selected several similar problems for you: 5910 5909 5906 5905 5902

正如题解所说 : 枚举kk,首先kk必须是nn的约数,然后就能算出每个数字应该出现多少次,O(n)O(n)检验即可。

时间复杂度O(nd(n))O(nd(n))。

#include<cstdio>
using namespace std;
int a[100010];
int b[100010];
int c[100010];
int main(){
    int T; scanf("%d",&T);
    while(T--){
        int n; scanf("%d",&n);
        for(int i=1;i<=n;i++){
            scanf("%d",&a[i]);
            c[a[i]]=false;
        }
        int t=0;
        for(int i=1;i<=n;i++){
            if(n%i==0){  // 是否可以被分成 i 份
                int x=1;bool K=true;
                while(x<n/i){
                    for(int j=1;j<=i;j++){
                        c[a[j]]++;
                    }
                    for(int j=i*x+1;j<=i*(x+1);j++){
                        if(c[a[j]])
                            c[a[j]]--;
                    }
                    for(int j=1;j<=i;j++){
                        if(c[a[j]]!=0){
                            c[a[j]]=0;
                            K=false;
                        }
                    }
                    if(K==false)
                        break;
                    x++;
                }
                for(int j=1;j<=i;j++)
                    c[a[j]]=false;
                if(K)
                    b[++t]=i;
            }
        }
        printf("%d",b[1]);
        for(int i=2;i<=t;i++)
            printf(" %d",b[i]);
        printf("\n");
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值