HDU 5908 Abelian Period (暴力+map)

35 篇文章 0 订阅
31 篇文章 0 订阅

Abelian Period

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 262144/131072 K (Java/Others)
Total Submission(s): 734    Accepted Submission(s): 295

Problem Description
Let S be a number string, and occ(S,x) means the times that number x occurs in S .

i.e. S=(1,2,2,1,3),occ(S,1)=2,occ(S,2)=2,occ(S,3)=1 .

String u,w are matched if for each number i , occ(u,i)=occ(w,i) always holds.

i.e. (1,2,2,1,3)(1,3,2,1,2) .

Let S be a string. An integer k is a full Abelian period of S if S can be partitioned into several continous substrings of length k , and all of these substrings are matched with each other.

Now given a string S , please find all of the numbers k that k is a full Abelian period of S .
 
Input
The first line of the input contains an integer T(1T10) , denoting the number of test cases.

In each test case, the first line of the input contains an integer n(n100000) , denoting the length of the string.

The second line of the input contains n integers S1,S2,S3,...,Sn(1Sin) , denoting the elements of the string.
 
Output
For each test case, print a line with several integers, denoting all of the number k . You should print them in increasing order.
Sample Input
  
  
2 6 5 4 4 4 5 4 8 6 5 6 5 6 5 5 6

Sample Output
  
  
3 6 2 4 8
Source
Recommend
wange2014   |   We have carefully selected several similar problems for you:  5932 5931 5930 5929 5928 
题解:将一个数组分成长度为k的几个连续区间,如果每个区间内各个元素出现的次数相同,则称k为一个阿贝尔周期,从小到大打印所有阿贝尔周期。暴力....

AC代码:
#include<bits/stdc++.h>
#include<algorithm>
using namespace std;
const int N = 100000+20;  
int a[N];
int temp[N];
int ans[N];
int n,cnt;
void solve(int k)
{
	for(int i=0;i<n;i++) temp[i]=a[i];
	
	sort(temp,temp+k);
	for(int i=k; i<=n; i=i+k)
	{
		sort(temp+i,temp+i+k);
		for(int j=0;j<k;j++)
		{
			if(temp[j]!=temp[i+j-k]) return ;
		}
	}
	ans[cnt++]=k;
}
int main()
{  
    int t;
    scanf("%d",&t);
    while(t--)
    {
    	scanf("%d",&n);
    	cnt=0;
    	int k=0;
    	for(int i=0;i<n;i++)
		{
			scanf("%d",&a[i]);
		}
    	for(int i=1;i<=n/2;i++)
    	{
    		if(n%i==0) solve(i);
		}
		ans[cnt++]=n;
		printf("%d",ans[0]);
		for(int i=1;i<cnt;i++)printf(" %d",ans[i]);
		puts("");
	}
    return 0; 
}   

用map也能艹过去....
#include<bits/stdc++.h>
#include<algorithm>
using namespace std;
const int N = 100000+20;  
int a[N],vis[N];
int solve(int k,int n)
{
	map<int ,int> map1,map2;
    for(int i=1; i<=k; i++)
        map1[a[i]]++;
    for(int i=k+1; i<=n-k+1; i+=k)
    {
        map2.clear();
        for(int j=0; j<k; j++)
        {
            int num=a[i+j];
            map2[num]++;
        }
        if(map1!=map2)
            return 0;
    }
    return 1;
}
int main()
{  
    int t,n,ans;
    scanf("%d",&t);
    while(t--)
    {
        memset(vis,0,sizeof(vis));
        scanf("%d",&n);
        for(int i=1; i<=n; i++)
        {
            scanf("%d",&a[i]);
        }

        for(int i=1; i<=n/2; i++)
        {
            if(!vis[i] && n%i==0)//如果2成立,那么如果2的倍数m也能被n整除,则m也成立
            {
                if(solve(i,n))
                {
                    for(int j=i; j<=n/2; j+=i)
                    {
                        if(j!=n && n%j==0)
                        {
                            vis[j]=1;
                        }
                    }
                }
            }
        }
        for(int i=1; i<=n; i++)
        {
            if(vis[i])
                printf("%d ",i);
        }  
		cout<<n<<endl;      
    }
    return 0; 
}   




  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值