【POJ 3259 Wormholes】+ Bellman-Ford

Description

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ’s farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..N, M (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input

Line 1: A single integer, F. F farm descriptions follow.
Line 1 of each farm: Three space-separated integers respectively: N, M, and W
Lines 2..M+1 of each farm: Three space-separated numbers (S, E, T) that describe, respectively: a bidirectional path between S and E that requires T seconds to traverse. Two fields might be connected by more than one path.
Lines M+2..M+W+1 of each farm: Three space-separated numbers (S, E, T) that describe, respectively: A one way path from S to E that also moves the traveler back T seconds.
Output

Lines 1..F: For each farm, output “YES” if FJ can achieve his goal, otherwise output “NO” (do not include the quotes).
Sample Input

2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8
Sample Output

NO
YES

Hint

For farm 1, FJ cannot travel back in time.
For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.

题意 : 先给出点的个数 N,以及正权双向边个数M,和负权单向边个数K,接下来M行给出a,b两条边的权值c此时建边要双向,在接下K行给出a,b两条边的权值注意此时建边要单向切权值为负即 -c

思路 :用Bellman搜索图的负权边,很巧妙的把物理学的负空间的概念迁移了一下,不过这过程也很自然,不怎么难想,写得很快

我也是第一次接触权值有负的图论题,也是初次接触Bellman-Ford算法,很好理解,百度下很详细,找不到好的讲解的话,我这推荐几篇 : http://blog.csdn.net/wyk1823376647/article/details/52739940

AC代码 :

#include<cstdio>
#include<algorithm>
using namespace std;
struct node{
   int x,y,z;
}st[5310];
int dis[510],nl;
int BellmanFord(int pl)
{
    int i,j,kl;
    for(i = 1 ; i <= nl ; i++)
        dis[i] = 100011;
    dis[1] = 0;
    for(i = 1 ; i <= nl - 1 ; i++){
        kl = 1;
        for(j = 1 ; j <= pl ; j++)
            if(dis[st[j].x] > dis[st[j].y] + st[j].z){
                dis[st[j].x] = dis[st[j].y] + st[j].z;
                kl = 0;
        }
        if(kl)
            break;
    }
    for(i = 1 ; i <= pl ; i++)
        if(dis[st[i].x] > dis[st[i].y] + st[i].z)
            return 0;
    return 1;
}
int main()
{
    int T,N,M,i,a,b,c;
    scanf("%d",&T);
    while(T--)
    {
        int pl = 0;
        scanf("%d%d%d",&nl,&N,&M);
        for(i = 1 ; i <= N ; i++){
            scanf("%d%d%d",&a,&b,&c);
            st[++pl].x = a;
            st[pl].y = b;
            st[pl].z = c;
            st[++pl].x = b;
            st[pl].y = a;
            st[pl].z = c;
        }
        for(i = 1 ; i <= M ; i++){
            scanf("%d%d%d",&a,&b,&c);
            st[++pl].x = a;
            st[pl].y = b;
            st[pl].z = -c;
        }
        if(BellmanFord(pl))
            printf("NO\n");
        else
            printf("YES\n");
    }
    return 0;
}
  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值