【HDU 1005 Frog’s Game】

14 篇文章 0 订阅

Mr. Frog’s Game

这里写图片描述
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 0 Accepted Submission(s): 0

Problem Description
One day, Mr. Frog is playing Link Game (Lian Lian Kan in Chinese).

In this game, if you can draw at most three horizontal or vertical head-and-tail-connected lines over the empty grids(the lines can be out of the whole board) to connect two non-empty grids with the same symbol or the two non-empty grids with the same symbol are adjacent, then you can change these two grids into empty and get several more seconds to continue the game.

Now, Mr. Frog starts a new game (that means there is no empty grid in the board). If there are no pair of grids that can be removed together,Mr. Frog will say ”I’m angry” and criticize you.

Mr. Frog is battle-scarred and has seen many things, so he can check the board in a very short time, maybe one second. As a Hong Kong Journalist, what you should do is to check the board more quickly than him, and then you can get out of the room before Mr. Frog being angry.

Input
The first line contains only one integer T (T≤500), which indicates the number of test cases.

For each test case, the first line contains two integers n and m (1≤n,m≤30).

In the next n lines, each line contains m integers, j-th number in the i-th line means the symbol on the grid(the same number means the same symbol on the grid).

Output
For each test case, there should be one line in the output.

You should output “Case #x: y”,where x is the case number(starting from 1), and y is a string representing the answer of the question. If there are at least one pair of grids that can be removed together, the y is “Yes”(without quote), else y is “No”.

Sample Input
2
3 3
1 2 1
2 1 2
1 2 1
3 3
1 2 3
2 1 2
3 2 1

Sample Output
Case #1: Yes
Case #2: No

Hint

first sample can be explained as below.
这里写图片描述

AC代码 :

#include<cstdio>
int pa[32][32];
int main()
{
    int T,nl = 0,N,M,i,j,pl;
    scanf("%d",&T);
    while(T--){
        pl = 0;
        scanf("%d%d",&N,&M);
        for(i = 1 ; i <= N; i++)
            for(j = 1 ; j <= M; j++)
                scanf("%d",&pa[i][j]);
        for(i = 1 ; i < M ; i++){
           for(j = i + 1 ; j <= M ; j++)
               if((pa[1][i] == pa[1][j]) || (pa[N][i] == pa[N][j]))
                   pl = 1;
            if(pl) break;
        }
        if(!pl){
        for(i = 1 ; i < N ; i++){
            for(j = i + 1 ; j <= N ; j++)
                if((pa[i][1] == pa[j][1]) || (pa[i][M] == pa[j][M]))
                    pl = 1;
            if(pl) break;
        }
        if(!pl){
        for(i = 1 ; i <= N ; i++){
            for(j = 1 ; j <= M ; j++){
           if(i!= N && pa[i][j] == pa[i + 1][j]) pl = 1;
           if(j!= M && pa[i][j] == pa[i][j + 1]) pl = 1;
            }
            if(pl) break;
        }
      }
    }
        if(pl)
            printf("Case #%d: Yes\n",++nl);
        else
            printf("Case #%d: No\n",++nl); 
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值