hdu4004The Frog's Games

这道题目以前做过。。但是今天来做,却做了将近3个小时才做出来。。。orz。。。

我问了男神。。。我看了。看来是要总结一下啦。。。不然下次碰到还是要调很久。。。。。

首先如果是整数。。。则有如下技巧。。。首先由4个变量。。le,ri,mid,ans。。。

首先控制结束。。。为(le<=ri)!!!

然后更新的时候结果到底输出什么??

用ans保存可行的mid,不断更新。。最后要求的值就在ans里面。。。(ps:因为ans已经代表了当前le和ri的最好的情况。。)

然后就是左右边界的确定。。。

整数为:

选右区间:l=mid+1;

选做区间:r=mid-1;

ans=mid,保存解。。。

整数处理是最坑的,浮点数无非是精度问题。。。。

浮点数的边界控制为(ri-le>eps)

选右区间:l=mid;

做左区间:ri=mid;

最后结果输出mid值。。。。

这个题目链接为:http://acm.hdu.edu.cn/showproblem.php?pid=4004

题目为:

The Frog's Games

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65768/65768 K (Java/Others)
Total Submission(s): 3395    Accepted Submission(s): 1645


Problem Description
The annual Games in frogs' kingdom started again. The most famous game is the Ironfrog Triathlon. One test in the Ironfrog Triathlon is jumping. This project requires the frog athletes to jump over the river. The width of the river is L (1<= L <= 1000000000). There are n (0<= n <= 500000) stones lined up in a straight line from one side to the other side of the river. The frogs can only jump through the river, but they can land on the stones. If they fall into the river, they
are out. The frogs was asked to jump at most m (1<= m <= n+1) times. Now the frogs want to know if they want to jump across the river, at least what ability should they have. (That is the frog's longest jump distance).
 

Input
The input contains several cases. The first line of each case contains three positive integer L, n, and m.
Then n lines follow. Each stands for the distance from the starting banks to the nth stone, two stone appear in one place is impossible.
 

Output
For each case, output a integer standing for the frog's ability at least they should have.
 

Sample Input
  
  
6 1 2 2 25 3 3 11 2 18
 

Sample Output
  
  
4 11
 

Source
 

Recommend
lcy   |   We have carefully selected several similar problems for you:   4001  4007  4006  4003  4008 
 
代码如下:

#include<cstdio>
#include<algorithm>
#include<iostream>
using namespace std;
const int maxn=500000+10;
int l,n,m;
int a[maxn];
bool judge(int mid)
{
    int pace=1;
    int pos=0;
    for(int i=1;i<=n;i++)
    {
       if (a[i]-a[pos]<=mid&&a[i+1]-a[pos]>mid)
         {
            pos = i;
            pace++;
         }
    }//三块石头之间的关系。。
    if(pace>m)
        return false;
    else
        return true;
}
int main()
{
    int le,ri,mid,mind;
    int pos,step,i,ans;
    while(scanf("%d%d%d",&l,&n,&m)!=EOF)
    {
        a[0]=0;
        a[n+1]=l;
        mind=0;
        for(i=1;i<=n;i++)
            scanf("%d",&a[i]);
         sort(a,a+n+1);
         for(i=1;i<=n+1;i++)
            {
                if(a[i]-a[i-1]>mind)
                   mind=a[i]-a[i-1];
            }
        le=mind;//最小距离为两块石头间的最大距离。。
        ri=l;
        while(ri>=le)
        {
            mid=(le+ri)/2;
            if(judge(mid))
                {
                   ri=mid-1;
                   ans=mid;
                }
            else
                  le=mid+1;
        }
        printf("%d\n",ans);
    }
    return 0;
}



  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值