Triangle LOVE
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 4603 Accepted Submission(s): 1805
Problem Description
Recently, scientists find that there is love between any of two people. For example, between A and B, if A don’t love B, then B must love A, vice versa. And there is no possibility that two people love each other, what a crazy world!
Now, scientists want to know whether or not there is a “Triangle Love” among N people. “Triangle Love” means that among any three people (A,B and C) , A loves B, B loves C and C loves A.
Your problem is writing a program to read the relationship among N people firstly, and return whether or not there is a “Triangle Love”.
Input
The first line contains a single integer t (1 <= t <= 15), the number of test cases.
For each case, the first line contains one integer N (0 < N <= 2000).
In the next N lines contain the adjacency matrix A of the relationship (without spaces). Ai,j = 1 means i-th people loves j-th people, otherwise Ai,j = 0.
It is guaranteed that the given relationship is a tournament, that is, Ai,i= 0, Ai,j ≠ Aj,i(1<=i, j<=n,i≠j).
Output
For each case, output the case number as shown and then print “Yes”, if there is a “Triangle Love” among these N people, otherwise print “No”.
Take the sample output for more details.
Sample Input
2
5
00100
10000
01001
11101
11000
5
01111
00000
01000
01100
01110
Sample Output
Case #1: Yes
Case #2: No
Author
BJTU
拓扑一下,因为ai,i != 1,ai,j != a j ,i ,很容易想到,只要存在不能全部转化为入度为 0 的节点,就一定存在一个满足题意的解~~~(居然突发奇想用vector写,真是zz)
AC代码 :
#include<bits/stdc++.h>
using namespace std;
int in[2010],head[2010],n,num;
char st[2010][2010];
struct node{
int from,to,next;
}no[2000010];
int topsort(){
int cut = 0;
while(cut < n){
int falg = 1;
for(int i = 1 ; i <= n ; i++){
if(in[i]) continue;
cut++,falg = 0,in[i]--;
for(int j = head[i]; j != -1 ; j = no[j].next)
in[no[j].to]--;
}
if(falg) return 1;
}
return 0;
}
void add(int a,int b){
node W = {a,b,head[a]};
no[num] = W;
head[a] = num++;
}
void init(){
num = 0;
memset(in,0,sizeof(in));
memset(head,-1,sizeof(head));
for(int i = 1; i <= n ; i++){
scanf("%s",st[i] + 1);
for(int j = 1 ; j <= n ; j++)
if(st[i][j] == '1')
in[j]++,add(i,j);
}
}
int main()
{
int t,i,j,cut,vis = 0,nl = 0,k,m;
scanf("%d",&t);
while(t--){
scanf("%d",&n);
init();
vis = topsort();
printf("Case #%d: ",++nl);
if(vis) printf("Yes\n");
else printf("No\n");
}
return 0;
}