【HDU 1568 Fibonacci】+ 数学

Fibonacci
Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4872 Accepted Submission(s): 2258

Problem Description
2007年到来了。经过2006年一年的修炼,数学神童zouyu终于把0到100000000的Fibonacci数列
(f[0]=0,f[1]=1;f[i] = f[i-1]+f=2”>i-2)的值全部给背了下来。
接下来,CodeStar决定要考考他,于是每问他一个数字,他就要把答案说出来,不过有的数字太长了。所以规定超过4位的只要说出前4位就可以了,可是CodeStar自己又记不住。于是他决定编写一个程序来测验zouyu说的是否正确。

Input
输入若干数字n(0 <= n <= 100000000),每个数字一行。读到文件尾。

Output
输出f[n]的前4个数字(若不足4个数字,就全部输出)。

Sample Input

0
1
2
3
4
5
35
36
37
38
39
40

Sample Output

0
1
1
2
3
5
9227
1493
2415
3908
6324
1023
先看对数的性质,loga(b^c)=c * loga(b),loga(b * c)=loga(b)+loga(c);
这公式给跪. an=(1/√5) * ( (1+√5)/2)^n-((1-√5)/2)^n](n=1,2,3…..) ~~ 运用对数公式求就好~~~

AC代码 :

#include<cstdio>
#include<cmath>
typedef long long LL;
int fb[22] = {0,1};
int main()
{
    LL N;
    for(int i = 2 ; i <= 20 ; i++)
            fb[i] = fb[i - 1] + fb[i - 2];
    while(scanf("%lld",&N) != EOF){
        if(N <= 20) printf("%d\n",fb[N]);
        else{
            double ans = -0.5 * log(5.0) / log(10.0) + ((double)N) * log((sqrt(5.0) + 1.0) / 2.0) / log(10.0);
            ans -= floor(ans); ans = pow(10.0,ans);
            while(ans < 1000)
                ans *= 10;
            printf("%d\n",(int)ans);
        }
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值