【POJ 3279 Fliptile】 + 反转 开关问题

72 篇文章 1 订阅
10 篇文章 0 订阅

Fliptile
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 8221 Accepted: 3072

Description

Farmer John knows that an intellectually satisfied cow is a happy cow who will give more milk. He has arranged a brainy activity for cows in which they manipulate an M × N grid (1 ≤ M ≤ 15; 1 ≤ N ≤ 15) of square tiles, each of which is colored black on one side and white on the other side.

As one would guess, when a single white tile is flipped, it changes to black; when a single black tile is flipped, it changes to white. The cows are rewarded when they flip the tiles so that each tile has the white side face up. However, the cows have rather large hooves and when they try to flip a certain tile, they also flip all the adjacent tiles (tiles that share a full edge with the flipped tile). Since the flips are tiring, the cows want to minimize the number of flips they have to make.

Help the cows determine the minimum number of flips required, and the locations to flip to achieve that minimum. If there are multiple ways to achieve the task with the minimum amount of flips, return the one with the least lexicographical ordering in the output when considered as a string. If the task is impossible, print one line with the word “IMPOSSIBLE”.

Input
Line 1: Two space-separated integers: M and N
Lines 2..M+1: Line i+1 describes the colors (left to right) of row i of the grid with N space-separated integers which are 1 for black and 0 for white

Output
Lines 1..M: Each line contains N space-separated integers, each specifying how many times to flip that particular location.

Sample Input

4 4
1 0 0 1
0 1 1 0
0 1 1 0
1 0 0 1

Sample Output

0 0 0 0
1 0 0 1
1 0 0 1
0 0 0 0

每一次反之当前位置总会连到相邻边~换个角度思考~其实只要第一行的反转方案确定~实际上就已经决定了本次的反转翻案~枚举第一行的所有可能方案~依次推出剩下的反转翻案(这里面也是有技巧的具体看代码~实现)~然后判断本方案是否可解~输出最少反转次数~反之返回 -1~最后每次更新保存最优解即可~~

AC代码:

#include<cstdio>
#include<cstring>
using namespace std;
int fx[5] = {0,0,0,-1,1},fy[5] = {1,-1,0,0,0};
int N,M,ma[20][20],pa[20][20],vis[20][20];
int get(int x,int y){
    int sum = ma[x][y];
    for(int i = 0 ; i < 5 ; i++){
        int ex = x + fx[i],ey = y + fy[i];
        if(ex >= 0 && ey >=0 && ex < M && ey < N)
            sum += vis[ex][ey];
    }
    return sum % 2; // 改点是否仍需要反转
}
int CA(){
   for(int i = 1 ; i < M ; i++)
       for(int j = 0 ; j < N ; j++)
           if(get(i - 1 , j) != 0) // 改点上面的那个是黑色的话,这是最后的机会反转它
               vis[i][j] = 1;
   for(int i = 0 ; i < N ; i++) // 判断最后一行是否为全白
        if(get(M - 1 , i) != 0)
            return -1;
   int cut = 0;
   for(int i = 0 ; i < M ; i++)
       for(int j = 0 ; j < N ;j++)
          cut += vis[i][j];
   return cut;
}
void solve(){
    int ans = -1;
    for(int i = 0 ; i < 1 << N ; i++){ // 按字典序尝试第一行所有的可能
        memset(vis,0,sizeof(vis));
        for(int j = 0 ; j < N; j++)
            vis[0][N - j - 1] = i >> j & 1; // 判断 j 元素是否在 i ”集合“中
        int num = CA();
        if(num >=0 && (ans < 0 || ans > num)){
            ans = num;
            memcpy(pa,vis,sizeof(vis)); // 保存最优解
        }
    }
    if(ans < 0) printf("IMPOSSIBLE\n");
    else{
        for(int i = 0 ; i < M; i++)
            for(int j = 0 ; j < N ; j++)
                printf("%d%c",pa[i][j],j + 1 == N ? '\n' : ' ');
    }
}
int main()
{
    while(scanf("%d %d",&M,&N) != EOF){
        for(int i = 0 ; i < M ; i++)
            for(int j = 0 ; j < N ;j++)
                scanf("%d",&ma[i][j]);
        solve();
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
根据提供的引用内容,可以得知这是一道关于迷宫问题的题目,需要使用Java语言进行编写。具体来说,这道题目需要实现一个迷宫的搜索算法,找到从起点到终点的最短路径。可以使用广度优先搜索或者深度优先搜索算法来解决这个问题。 下面是一个使用广度优先搜索算法的Java代码示例: ```java import java.util.*; public class Main { static int[][] maze = new int[5][5]; // 迷宫地图 static int[][] dir = {{0, 1}, {0, -1}, {1, 0}, {-1, 0}}; // 方向数组 static boolean[][] vis = new boolean[5][5]; // 标记数组 static int[][] pre = new int[5][5]; // 记录路径 public static void main(String[] args) { Scanner sc = new Scanner(System.in); for (int i = 0; i < 5; i++) { for (int j = 0; j < 5; j++) { maze[i][j] = sc.nextInt(); } } bfs(0, 0); Stack<Integer> stack = new Stack<>(); int x = 4, y = 4; while (x != 0 || y != 0) { stack.push(x * 5 + y); int t = pre[x][y]; x = t / 5; y = t % 5; } stack.push(0); while (!stack.empty()) { System.out.print(stack.pop() + " "); } } static void bfs(int x, int y) { Queue<Integer> qx = new LinkedList<>(); Queue<Integer> qy = new LinkedList<>(); qx.offer(x); qy.offer(y); vis[x][y] = true; while (!qx.isEmpty()) { int tx = qx.poll(); int ty = qy.poll(); if (tx == 4 && ty == 4) { return; } for (int i = 0; i < 4; i++) { int nx = tx + dir[i][0]; int ny = ty + dir[i][1]; if (nx >= 0 && nx < 5 && ny >= 0 && ny < 5 && maze[nx][ny] == 0 && !vis[nx][ny]) { vis[nx][ny] = true; pre[nx][ny] = tx * 5 + ty; qx.offer(nx); qy.offer(ny); } } } } } ``` 该代码使用了广度优先搜索算法,首先读入迷宫地图,然后从起点开始进行搜索,直到找到终点为止。在搜索的过程中,使用标记数组记录已经访问过的位置,使用路径数组记录路径。最后,使用栈来输出路径。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值