POJ 3279 Fliptile 反转

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 15599 Accepted: 5713

Description

Farmer John knows that an intellectually satisfied cow is a happy cow who will give more milk. He has arranged a brainy activity for cows in which they manipulate an M × N grid (1 ≤ M ≤ 15; 1 ≤ N ≤ 15) of square tiles, each of which is colored black on one side and white on the other side.

As one would guess, when a single white tile is flipped, it changes to black; when a single black tile is flipped, it changes to white. The cows are rewarded when they flip the tiles so that each tile has the white side face up. However, the cows have rather large hooves and when they try to flip a certain tile, they also flip all the adjacent tiles (tiles that share a full edge with the flipped tile). Since the flips are tiring, the cows want to minimize the number of flips they have to make.

Help the cows determine the minimum number of flips required, and the locations to flip to achieve that minimum. If there are multiple ways to achieve the task with the minimum amount of flips, return the one with the least lexicographical ordering in the output when considered as a string. If the task is impossible, print one line with the word "IMPOSSIBLE".

Input

Line 1: Two space-separated integers: M and N
Lines 2..M+1: Line i+1 describes the colors (left to right) of row i of the grid with N space-separated integers which are 1 for black and 0 for white

Output

Lines 1..M: Each line contains N space-separated integers, each specifying how many times to flip that particular location.

Sample Input

4 4
1 0 0 1
0 1 1 0
0 1 1 0
1 0 0 1

Sample Output

0 0 0 0
1 0 0 1
1 0 0 1
0 0 0 0

题意:欲将M*N大小的网格中所有数值为1的翻转为0,求翻转次数最少的一组方案,按字典序输出,输出结果中的1所处的位置表示要翻转的位置:

 

题解:改题要注意一定要先确定第一行的翻转情况,一共有2^n中情况。根据翻转一格会影响上下左右周围的砖块黑白情况,所以最方便的是根据第 i 行的数值来确定第 i+1 行是否要翻转,例如:题目中的例子(0,0)数值是1需要通过下面的(1,0)来翻转使其变为0。然后需要判断网格的最后一行是否都为0,若满足则存下来,最后选出最小的一组方案。

 

#include"iostream"
#include"string.h"
using namespace std;
int visit[20][20];
int data[20][20];
int data1[20][20];
int visit1[20][20];
int ans,ams;
void fli(int x,int y)
{
    ams++;
    visit1[x][y]=1;
    data1[x][y]=1-data1[x][y];
    data1[x-1][y]=1-data1[x-1][y];
    data1[x+1][y]=1-data1[x+1][y];
    data1[x][y+1]=1-data1[x][y+1];
    data1[x][y-1]=1-data1[x][y-1];
}
int main()
{
    int m,n;
    cin>>m>>n;
    for(int i=0;i<m;i++)
        for(int j=0;j<n;j++)
        cin>>data[i][j];
        ans=100000;
    for(int i=0;i<(1<<n);i++)
    {
        memset(visit1,0,sizeof(visit1));
        memcpy(data1,data,sizeof(data));
        int k=i;
        ams=0;
        for(int j=0;j<n;j++)//第一行枚举翻转
          {
             if(k&1)fli(0,j);
             k=k>>1;
          }
        for(int j=1;j<m;j++)//第二行后面的翻转
            for(int s=0;s<n;s++)
        {
            if(data1[j-1][s]==1)fli(j,s);
        }
        int j;
        for(j=0;j<n;j++)//判断最后一行
            if(data1[m-1][j]==1)break;
        if((ans>ams)&&(j==n)){
            memcpy(visit,visit1,sizeof(visit1));
            ans=ams;
        }
    }
    if(ans==100000)
    {cout<<"IMPOSSIBLE"<<endl;
    return 0;
    }
    for(int i=0;i<m;i++)
       {
           for(int j=0;j<n;j++)
    {
        if(j==0)cout<<visit[i][j];
        else cout<<" "<<visit[i][j];
    }
    cout<<endl;
       }
       return 0;
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值