Euclid’s Game
Time Limit: 1000MS
Memory Limit: 65536K
Total Submissions: 9356
Accepted: 3830
Description
Two players, Stan and Ollie, play, starting with two natural numbers. Stan, the first player, subtracts any positive multiple of the lesser of the two numbers from the greater of the two numbers, provided that the resulting number must be nonnegative. Then Ollie, the second player, does the same with the two resulting numbers, then Stan, etc., alternately, until one player is able to subtract a multiple of the lesser number from the greater to reach 0, and thereby wins. For example, the players may start with (25,7):
25 7
11 7
4 7
4 3
1 3
1 0
an Stan wins.
Input
The input consists of a number of lines. Each line contains two positive integers giving the starting two numbers of the game. Stan always starts.
Output
For each line of input, output one line saying either Stan wins or Ollie wins assuming that both of them play perfectly. The last line of input contains two zeroes and should not be processed.
Sample Input
34 12
15 24
0 0
Sample Output
Stan wins
Ollie wins
如果 a > b ,swap(a,b), if(b % a == 0) 者 必胜
按自由度可分为以下两类 :
1) b - a < a ,此时没多余选择只能 b - a;
2)b - a > a ,假设 存在 x 使得 b - ax < a,若 减去 a(x - 1)后的状态是必胜态,此时 b - ax后的状态是a(x - 1)后的唯一可转移的状态,也是必败态,所以次状态是必胜态,先到达该状态的人,必胜
AC代码:
#include<cstdio>
#include<algorithm>
using namespace std;
int main()
{
int a,b;
while(scanf("%d %d",&a,&b) != EOF && (a || b)){
int ok = 1;
while(1){
if(a > b) swap(a,b);
if(b % a == 0) break;
if(b - a > a) break;
b -= a,ok = !ok;
}
if(ok) puts("Stan wins");
else puts("Ollie wins");
}
return 0;
}