【UVA 673 Parentheses】 & 栈

You are given a string consisting of parentheses () and []. A string of this type is said to be correct:
(a) if it is the empty string
(b) if A and B are correct, AB is correct,
(c) if A is correct, (A) and [A] is correct.
Write a program that takes a sequence of strings of this type and check their correctness. Your
program can assume that the maximum string length is 128.
Input
The file contains a positive integer n and a sequence of n strings of parentheses ‘()’ and ‘[]’, one string
a line.
Output
A sequence of ‘Yes’ or ‘No’ on the output file.
Sample Input
3
([])
(([()])))
([()])()
Sample Output
Yes
No
Yes

题意 : 检查给出的字符串是否括号配对

思路 : 栈存左括号,遇到右括号配对,空字符串也为 Yes

AC代码:

#include<cstdio>
#include<cmath>
#include<deque>
#include<stack>
#include<iostream>
#include<queue>
#include<vector>
#include<cstring>
#include<algorithm>
using namespace std;
const int MAX = 1e5 + 10;
const int INF = 1e9 + 7;
typedef long long LL;
string s;
int nl;
int main()
{
    int n;
    scanf("%d",&n);
    getchar();
    while(n--){
        getline(cin,s);
        if(s.size() == 0){
            puts("Yes");
            continue;
        }
        int ok = 1;
        stack <char> q;
        for(int i = 0; i < s.size(); i++)
            if(s[i] == '(' || s[i] == '[')
                q.push(s[i]);
            else{
                if(q.empty()){
                    ok = 0; break;
                }
                char o = q.top();
                q.pop();
                if(s[i] == ')' && o != '(') ok = 0;
                if(s[i] == ']' && o != '[') ok = 0;
                if(!ok) break;
            }
            if(ok && q.empty()) puts("Yes");
            else puts("No");
        }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值