uva673

题目:
You are given a string consisting of parentheses () and []. A string of this type is said to be correct:
(a)
if it is the empty string
(b)
if A and B are correct, AB is correct,
(c)
if A is correct, (A ) and [A ] is correct.
Write a program that takes a sequence of strings of this type and check their correctness. Your program can assume that the maximum string length is 128.
Input
The file contains a positive integer n and a sequence of n strings of parentheses () and [], one string a line.
Output
A sequence of Yes or No on the output file.
Sample Input
3
([])
(([()])))
([()])()
Sample Output
Yes
No
Yes

思路:括号匹配。。将左括号放入栈中,遇到右括号就进行匹配。。如果匹配了就pop出来 如果不匹配就是不匹配。。到字符串尾巴的时候还要判断栈中是否已经为空,不为空表示有左括号多出来。

代码:

#include <iostream>
#include <string>
using namespace std;
#include <stack>
int main()
{
    string s;
    int m, i;
    cin >> m;
    stack<char> ss;
    getchar();
    while (m--)
    {
        getline(cin, s);
        for (i = 0; i< s.length(); i++)
        {
            if (s[i] == '(' || s[i] == '[')
                ss.push(s[i]);
            if (ss.empty())
                break;
            else if (s[i]==')')
            {
                if (ss.top() == '(' )
                {
                    ss.pop();
                }
                else
                    break;
            }
            else if (s[i]==']')
            {
                if (ss.top() == '[' )
                {
                    ss.pop();
                }
                else
                    break;
            }
        }

        if (i==s.length() && ss.empty())
            printf("Yes\n");
        else
            printf("No\n");
        while (!ss.empty())
            ss.pop();
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值