数据结构实验之二叉树五:层序遍历

Problem Description

已知一个按先序输入的字符序列,如abd,,eg,,,cf,,,(其中,表示空结点)。请建立二叉树并求二叉树的层次遍历序列。

Input
 输入数据有多行,第一行是一个整数 t (t<1000) ,代表有 t 行测试数据。每行是一个长度小于 50 个字符的字符串。
Output
 输出二叉树的层次遍历序列。
Sample Input
2
abd,,eg,,,cf,,,
xnl,,i,,u,,
Sample Output
abcdefg
xnuli
#include <bits/stdc++.h>
using namespace std;
char a[55];
int l;
typedef struct tnode
{
    char data;
    struct tnode *lc,*rc;
}*tree;

tree create()
{
    tree t;
    char c;
    c=a[l++];
    if(c==','){
        t=NULL;
    }
    else {
        t=new(tnode);
        t->data=c;
        t->lc=create();
        t->rc=create();
    }
    return t;
}

void cengxu(tree t)
{
    tree temp[100];
    int in=0,out=0;
    temp[in++]=t;
    while(in>out){
        if(temp[out]){
            cout<<temp[out]->data;
            temp[in++]=temp[out]->lc;
            temp[in++]=temp[out]->rc;
        }
        out++;
    }

}
int main()
{
    int n;
    cin>>n;
    while(n--){
        tree t;
        cin>>a;
        l=0;
        t=create();
        cengxu(t);
        cout<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
好的,下面是层序遍历二叉树的实验报告: 一、实验目的 通过本实验,了解二叉树层序遍历算法,掌握用队列实现二叉树层序遍历的方法。 二、实验内容 1. 二叉树层序遍历算法 层序遍历是按照从上到下、从左到右的顺序遍历二叉树的每个结点。具体实现方法是:从根结点开始,将根结点入队,然后依次取出队首结点,将其左右子结点入队,直到队列为空。 2. 用队列实现二叉树层序遍历的方法 为了实现层序遍历,需要用到队列的数据结构。具体实现方法是:将根结点入队,然后依次取出队首结点,将其左右子结点入队,直到队列为空。 三、实验步骤 1. 定义二叉树结构体 ``` struct TreeNode { int val; struct TreeNode *left; struct TreeNode *right; }; ``` 2. 定义队列结构体 ``` struct QueueNode { struct TreeNode *node; struct QueueNode *next; }; ``` 3. 实现队列的入队和出队操作 ``` void enqueue(struct QueueNode **rear, struct TreeNode *node) { struct QueueNode *newNode = (struct QueueNode*)malloc(sizeof(struct QueueNode)); newNode->node = node; newNode->next = NULL; if (*rear == NULL) { *rear = newNode; } else { (*rear)->next = newNode; *rear = newNode; } } struct TreeNode* dequeue(struct QueueNode **front) { if (*front == NULL) { return NULL; } else { struct TreeNode *node = (*front)->node; struct QueueNode *temp = *front; *front = (*front)->next; free(temp); return node; } } ``` 4. 实现二叉树层序遍历函数 ``` void levelOrder(struct TreeNode* root) { if (root == NULL) { return; } struct QueueNode *front = NULL, *rear = NULL; enqueue(&rear, root); while (front != NULL) { struct TreeNode *node = dequeue(&front); printf("%d ", node->val); if (node->left != NULL) { enqueue(&rear, node->left); } if (node->right != NULL) { enqueue(&rear, node->right); } } } ``` 四、实验结果 假设有如下二叉树: ``` 1 / \ 2 3 / \ \ 4 5 6 ``` 层序遍历的结果应该是:1 2 3 4 5 6。 、实验总结 本实验通过实现二叉树层序遍历算法,加深了对二叉树的理解,同时也掌握了用队列实现二叉树层序遍历的方法。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值