数据结构实验之二叉树五:层序遍历

Problem Description

已知一个按先序输入的字符序列,如abd,,eg,,,cf,,,(其中,表示空结点)。请建立二叉树并求二叉树的层次遍历序列。

Input
 输入数据有多行,第一行是一个整数 t (t<1000) ,代表有 t 行测试数据。每行是一个长度小于 50 个字符的字符串。
Output
 输出二叉树的层次遍历序列。
Sample Input
2
abd,,eg,,,cf,,,
xnl,,i,,u,,
Sample Output
abcdefg
xnuli
#include <bits/stdc++.h>
using namespace std;
char a[55];
int l;
typedef struct tnode
{
    char data;
    struct tnode *lc,*rc;
}*tree;

tree create()
{
    tree t;
    char c;
    c=a[l++];
    if(c==','){
        t=NULL;
    }
    else {
        t=new(tnode);
        t->data=c;
        t->lc=create();
        t->rc=create();
    }
    return t;
}

void cengxu(tree t)
{
    tree temp[100];
    int in=0,out=0;
    temp[in++]=t;
    while(in>out){
        if(temp[out]){
            cout<<temp[out]->data;
            temp[in++]=temp[out]->lc;
            temp[in++]=temp[out]->rc;
        }
        out++;
    }

}
int main()
{
    int n;
    cin>>n;
    while(n--){
        tree t;
        cin>>a;
        l=0;
        t=create();
        cengxu(t);
        cout<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值