数据结构实验之二叉树五:层序遍历 (sdut OJ 3344)

18 篇文章 0 订阅
18 篇文章 0 订阅

数据结构实验之二叉树五:层序遍历

Time Limit: 1000ms   Memory limit: 65536K  有疑问?点这里^_^

题目描述

已知一个按先序输入的字符序列,如abd,,eg,,,cf,,,(其中,表示空结点)。请建立二叉树并求二叉树的层次遍历序列。

输入

  输入数据有多行,第一行是一个整数t (t<1000),代表有t行测试数据。每行是 一个长度小于50个字符的字符串。

输出

  输出二叉树的层次遍历序列。

示例输入

2
abd,,eg,,,cf,,,
xnl,,i,,u,,

示例输出

abcdefg
xnuli

提示

 

来源

 xam

示例程序


#include <bits/stdc++.h>

using namespace std;

struct node
{
    char data;
    struct node *lchild, *rchild;
} *root;

int top;
int s = 0;
char st[55];
struct node *creat()
{
    struct node *root;
    if(st[top++] == ',')
        root = NULL;
    else
    {
        root = (struct node*)malloc(sizeof(struct node));
        root->data = st[top-1];
        root->lchild = creat();   //建立左子树;
        root->rchild = creat();   //建立右子树;
    }
    return root;
}

void Cengxu(struct node *root)
{
    queue<node *> q;   //建队列
    if(root)
    {
        printf("%c", root->data);
        q.push(root);  //输出根节点并入队
    }

    while(! q.empty())
    {
        root = q.front();  //访问队首元素
        q.pop();           //删除队首(第一个头根)
        if(root->lchild)
        {
            printf("%c", root->lchild->data); // 从此头跟的左子树,依次输出
            q.push(root->lchild);
        }
         if(root->rchild)
        {
            printf("%c", root->rchild->data); // 从此头跟的右子树,依次输出
            q.push(root->rchild);
        }
    }
}
int main()
{
    int t;
    scanf("%d", &t);
    while(t--)
    {
        scanf("%s", st);
        top = 0;
        root = creat();
        Cengxu(root);
        cout << endl;
    }
    return 0;
}


  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值