安装好 torch-1.1.0-cp36-cp36m-win_amd64.whl后提示torch.nn.TransformerEncoderLayer 不能用

问题:

     安装好  torch-1.1.0-cp36-cp36m-win_amd64.whl后提示torch.nn.TransformerEncoderLayer 不能用

     提示错误为:'torch.nn' has no attribute 'TransformerEncoderLayer'

解决方法: 

     安装Torch包1.2 进行解决

解决方案来源:

1.PyTorch中Transformer模型的使用 

https://www.jianshu.com/p/23b527e0f696

2.Pytorch1.2 cpu版本安装教程(附加GPU下载)

 在这里插入图片描述

https://blog.csdn.net/qq_41375318/article/details/102483339

3.使用Pip安装时速度慢或是下载不下来时直接在官网下载到本地进行安装

https://download.pytorch.org/whl/torch_stable.html 页面如下

4. 安装:

pip install 下载的文件路径名称 

 

©️2020 CSDN 皮肤主题: 大白 设计师: CSDN官方博客 返回首页
实付0元
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、C币套餐、付费专栏及课程。

余额充值