poj3669Meteor Shower

大致题意:流星要撞击地球,给你n组坐标和对应的时间,表示流星走到这一点要爆炸的时间,问你某人一开始在坐标(0,0)地点是否能在流星爆炸前逃到安全区域。

解题思路:用bfs遍历所有可能爆炸的情况,现将坐标构建成一个地图map,将map初始化为-1,将时间t,赋给所对应的坐标,因为爆炸点有很多,可能有爆炸的重叠的部分,这重叠部分的爆炸时间可能不同,所以要比较一点的爆炸时间,将最小的时间赋给这一点,(最小时间最先爆炸!!!)(0,0)这一点要单独判断一下,如果(0,0)时刻的时间正好是t,那就被炸死。很多详解请见代码!!!

Bessie hears that an extraordinary meteor shower is coming; reports say that these meteors will crash into earth and destroy anything they hit. Anxious for her safety, she vows to find her way to a safe location (one that is never destroyed by a meteor) . She is currently grazing at the origin in the coordinate plane and wants to move to a new, safer location while avoiding being destroyed by meteors along her way.

The reports say that M meteors (1 ≤ M ≤ 50,000) will strike, with meteor i will striking point (XiYi) (0 ≤ X≤ 300; 0 ≤ Y≤ 300) at time Ti (0 ≤ Ti  ≤ 1,000). Each meteor destroys the point that it strikes and also the four rectilinearly adjacent lattice points.

Bessie leaves the origin at time 0 and can travel in the first quadrant and parallel to the axes at the rate of one distance unit per second to any of the (often 4) adjacent rectilinear points that are not yet destroyed by a meteor. She cannot be located on a point at any time greater than or equal to the time it is destroyed).

Determine the minimum time it takes Bessie to get to a safe place.

Input

* Line 1: A single integer: M
* Lines 2..M+1: Line i+1 contains three space-separated integers: XiYi, and Ti

Output

* Line 1: The minimum time it takes Bessie to get to a safe place or -1 if it is impossible.

Sample Input
4
0 0 2
2 1 2
1 1 2
0 3 5
Sample Output
5
#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<queue>
using namespace std;
int dir[5][2]= {0,1,0,-1,1,0,-1,0,0,0},n;
int map[310][310],book[310][310];
struct node
{
    int x,y,t;
};
int bfs()
{
    node now,tmp;
    queue<node>q;
    now.x=0;
    now.y=0;
    now.t=0;
    book[0][0]=1;
    q.push(now);
    while(!q.empty())
    {
        now=q.front();
        q.pop();
        if(map[now.x][now.y]==-1)  //跑到安全区域后就可以返回
        {
            return now.t;
        }
        for(int i=0; i<4; i++)
        {
            tmp.x=now.x+dir[i][0];
            tmp.y=now.y+dir[i][1];
            //判断坐标是否满足条件,这点是否走过,是否小于爆炸时间,或者这一点不在爆炸区域内,满足以上就入队
            if(tmp.x>=0&&tmp.y>=0&&(map[tmp.x][tmp.y]==-1||now.t+1<map[tmp.x][tmp.y])&&!book[tmp.x][tmp.y])
            {
                tmp.t=now.t+1;
                book[tmp.x][tmp.y]=1;
                q.push(tmp);
            }
        }
    }
    return -1;
}

int main()
{
    while(~scanf("%d",&n))
    {
        int x,y,st;
        memset(book,0,sizeof(book));
        memset(map,-1,sizeof(map));   //将地图初始化位-1
        for(int i=1;i<=n;i++)
        {
            scanf("%d%d%d",&x,&y,&st);
            for(int i=0; i<5; i++)
            {
                int tx=x+dir[i][0];
                int ty=y+dir[i][1];
                if(tx<0||ty<0)continue;
                //将最小的时间赋给地图,因为时间最小最小爆炸
                if(map[tx][ty]==-1)map[tx][ty]=st;
                if(map[tx][ty]>st)map[tx][ty]=min(map[tx][ty],st);
            }
        }
        if(map[0][0]==0)   //如果在0时刻在(0,0)位置爆炸,将会被炸死
        {
            printf("-1\n");
            continue;
        }
        printf("%d\n",bfs());
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值