Maximum Subsequence Sum (25 分)

Given a sequence of K integers { N​1​​, N​2​​, ..., N​K​​ }. A continuous subsequence is defined to be { N​i​​, N​i+1​​, ..., N​j​​ } where 1≤i≤j≤K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (≤10000). The second line contains K numbers, separated by a space.

Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:

10
-10 1 2 3 4 -5 -23 3 7 -21

Sample Output:

10 1 4

题目分析:

这道题的题意是输出最大连续子列和并输出最大连续子列和的第一个元素和最后一个元素。当其序列全为负数时,输出0并输出序列的第一个元素和最后一个元素。这道题的解法和前面那道题很类似,只不过这个题多了要输出连续子列和的第一个元素和最后一个元素。解这道题还是采用更新sum的方法,当sum小于0时重置sum,因为sum小于0的时候只会使后面的子列和更小。然后当sum大于前面的最大值(Max)时,更新sum,同时记录现在的下标。当遍历完序列后,前面记录的下标就是最大连续子列和最后一个元素的下标。然后可以再从这个元素往前遍历,当其等于前面的Max的时候,说明找到了最大连续子列和的第一个元素。这里要注意,前面有可能会有一部分的0,所以不能直接break。

代码如下:

#include <iostream>

using namespace std;

int main()
{
    int n;
    cin >> n;

    int a[n], i, j = 0, k = -1, l, sum = 0, Max = 0, flag = 0;

    for( i=0; i<n; i++)
		cin >> a[i];

	for( i=0; i<n; i++) {     
		sum = sum + a[i];
		if( sum > Max) {
			Max = sum;
			k = i;    //用K标记最大连续子列和的最后一个元素
		}
		if(sum < 0) {   //当小于0的时候更新
			sum = 0;
		}
		if(a[i] >= 0) {   //看是不是都是负数
			flag = 1;
		}
	}
    sum = 0;
    for(i=k; i>=0; i--) {
		sum = sum + a[i];  
		if(sum == Max) {  //通过从K往前开始循环,找第一个元素
			j = i;      //这里要注意前面有可能先有一段0 也要算进去
		}
    }

    if(Max) {
		cout << Max << " " << a[j] << " " << a[k] << endl;   //存在最大子列和的情况
    } else if (flag)
		cout << 0 << " " << 0 << " " << 0 << endl;       //最大子列和为0的情况
	else
		cout << 0 <<  " " << a[0] << " " << a[n-1] << endl;    //全为负数,输出第一个和最后一个
    return 0;
}

 

 

 

 

 



 


 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值