Maximum Subsequence Sum(最大子序列)

Given a sequence of K integers { N​1​​, N​2​​, …, N​K​​ }. A continuous subsequence is defined to be { N​i​​, N​i+1​​, …, N​j​​ } where 1≤i≤j≤K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.
Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (≤10000). The second line contains K numbers, separated by a space.
Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:

10
-10 1 2 3 4 -5 -23 3 7 -21

Sample Output

10 1 4

思路: 从头开始遍历,寻找sum最大值的同时记录右端点(左端点可通过sum最大值再次遍历求出)。
如何寻找sum最大值: sum为正值时,对后面的序列是有一定会有贡献的所以不必更新,而当sum为负值时对后面的序列无贡献,那么就相当于把之前的序列切掉,把后面的序列当新的处理。每遍历一个元素就检查一遍sum是否为零即可。
易错点:
①全为负数要单独检查。
②全为零。(是一种特殊情况虽不需特殊处理但要想到)
③寻找最左端时,不要直接break,前面可能还有零。如 0 0 1 2 3 4时。

#include <iostream>
#include<bits/stdc++.h>
using namespace std;
int num[10005];
int main()
{
    int n;
    cin >> n;
    for(int i = 1; i<= n;i++)
       cin >> num[i];
    int sum = 0, maxsum = 0, end_ = 0,st = 0, flag = 0;
    for(int i = 1;i <= n;i++)
    {
       sum += num[i];
       if(sum < 0)
          sum = 0;///重新开始
       if(sum>maxsum)///要求索引值最小,所以不用加等于也不用考虑123000后面的零
       {
          maxsum = sum;
          end_ = i;
       }
       if(num[i]>=0)
         flag = 1;///看是不是全为负
    }
    sum = 0;
    for(int i = end_;i >= 1;i--)
      {
         sum = sum + num[i];
         if(sum == maxsum)
            st = i;
      }
    if(!flag)
      printf("0 %d %d",num[1], num[n]);
    else
      printf("%d %d %d",maxsum, num[st], num[end_])}
}

原文链接https://blog.csdn.net/W_Dreamland/article/details/88561573

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值