文章标题 HDU 1009 : FatMouse' Trade(贪心)

FatMouse’ Trade

Problem Description
FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.
The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.

Input
The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1’s. All integers are not greater than 1000.

Output
For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.

Sample Input
5 3
7 2
4 3
5 2
20 3
25 18
24 15
15 10
-1 -1

Sample Output
13.333
31.500

Author
CHEN, Yue

Source
ZJCPC2004
题意:有一只老鼠,想吃它最爱的食物,现在他手上有m磅毛最喜欢的食物,然后现在有n个房间,每个房间有一只猫,然后每个房间有j【i】磅老鼠喜欢的食物,需要用f【i】磅猫的食物去交换,其中,老鼠可以用同样的比例(比如a%*f【i】去换a%*j【i】)的食物。问最终能获得的最多的老鼠的食物。
分析:这是一道贪心的题目,有余可以用相同的比例的猫的食物交换老鼠的食物,所以可以将j【i】/f【i】的值保存起来放在val里面,val的值越大,说明相同的猫的食物可以换取更多的老鼠的食物,将val排序,这就是这道题的贪心策略
代码:

#include<iostream>
#include<string>
#include<cstdio>
#include<cstring>
#include<vector>
#include<math.h>
#include<map>
#include<queue> 
#include<algorithm>
using namespace std;
const int inf = 0x3f3f3f3f;
struct node {
    int j,f;
    double val;
    bool operator <(const node &t) const {
         return val > t.val;
    }
};
node a[1005];
int main ()
{
    int n,m;
    while (scanf ("%d%d",&m,&n)!=EOF){
        if(n==-1&&m==-1) break; 
        for (int i=0;i<n;i++){
            scanf ("%d%d",&a[i].j,&a[i].f);
            a[i].val=(double) a[i].j/a[i].f;
        } 
        sort (a,a+n);]
        int k=0;
        double ans=0;]
        while (k<n&&m){
            if (m>a[k].f){
                ans+=a[k].j;
                m-=a[k].f;
                k++;
            }
            else {
                ans+=(double)a[k].val*m;
                m=0;
            }
        }
        printf ("%.3f\n",ans);
    }       
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值