文章标题 HDU 5538 : House Building

11 篇文章 0 订阅

House Building

Description

Have you ever played the video game Minecraft? This game has been one of the world’s most popular game in recent years. The world of Minecraft is made up of lots of blocks in a 3D map. Blocks are the basic units of structure in Minecraft, there are many types of blocks. A block can either be a clay, dirt, water, wood, air, … or even a building material such as brick or concrete in this game.

Figure 1: A typical world in Minecraft.

Nyanko-san is one of the diehard fans of the game, what he loves most is to build monumental houses in the world of the game. One day, he found a flat ground in some place. Yes, a super flat ground without any roughness, it’s really a lovely place to build houses on it. Nyanko-san decided to build on a big flat ground, so he drew a blueprint of his house, and found some building materials to build.

While everything seems goes smoothly, something wrong happened. Nyanko-san found out he had forgotten to prepare glass elements, which is a important element to decorate his house. Now Nyanko-san gives you his blueprint of house and asking for your help. Your job is quite easy, collecting a sufficient number of the glass unit for building his house. But first, you have to calculate how many units of glass should be collected.

There are rows and columns on the ground, an intersection of a row and a column is a square,and a square is a valid place for players to put blocks on. And to simplify this problem, Nynako-san’s blueprint can be represented as an integer array . Which indicates the height of his house on the square of -th row and -th column. The number of glass unit that you need to collect is equal to the surface area of Nyanko-san’s house(exclude the face adjacent to the ground).

Input

The first line contains an integer indicating the total number of test cases.
First line of each test case is a line with two integers .
The lines that follow describe the array of Nyanko-san’s blueprint, the -th of these lines has integers , separated by a single space.

Output

For each test case, please output the number of glass units you need to collect to meet Nyanko-san’s requirement in one line.

Sample Input

2
3 3
1 0 0
3 1 2
1 1 0
3 3
1 0 1
0 0 0
1 0 1

Sample Output

30
20

Figure 2: A top view and side view image for sample test case 1.

题意: 在我的世界游戏中,在一个n*m的地面建造一个建筑,然后边长都为 1 的正方形表面的面积为一个单位面积,然后给出n*m个格子的高度,问这个建筑的裸露在表面的面积为多少。
分析: 求这个间建筑的表面的面积,可以一个格子一个格子来模拟,从每个格子的四个面看,如果高度比当前的格子高,说明这一面被另一面给挡住了,如果小就这要加上两个面相差的就行了,最后再加上面的面积。
代码:

#include<iostream>
#include<string>
#include<cstdio>
#include<cstring>
#include<vector>
#include<math.h>
#include<map>
#include<queue> 
#include<algorithm>
using namespace std;
const int inf = 0x3f3f3f3f;
int n,m;
int mp[55][55];
int dx[4]={1,0,-1,0};//四个方向的分量
int dy[4]={0,1,0,-1};
int main ()
{
    int t;
    scanf ("%d",&t);
    while (t--){
        scanf ("%d%d",&n,&m);
        int cnt=0;
        for (int i=1;i<=n;i++){
            for (int j=1;j<=m;j++){
                scanf ("%d",&mp[i][j]);
                if (mp[i][j]) cnt++;
            }
        }
        for (int i=0;i<=n+1;i++) {//在建筑外面再加上一层高度为0的
            mp[i][0]=0;
            mp[i][m+1]=0;
        }
        for (int i=0;i<=m+1;i++){
            mp[0][i]=0;
            mp[n+1][i]=0;
        } 
        int ans=0;
        for (int i=1;i<=n;i++){
            for (int j=1;j<=m;j++){//查看四个方向
                for (int k=0;k<4;k++){
                    if (mp[i][j]>mp[i+dx[k]][j+dy[k]]){
                        ans+=mp[i][j]-mp[i+dx[k]][j+dy[k]];
                    }
                }
            }
        }
        printf ("%d\n",ans+cnt);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值