hdu1542(线段树扫描线)

Atlantis

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 10190    Accepted Submission(s): 4344


Problem Description
There are several ancient Greek texts that contain descriptions of the fabled island Atlantis. Some of these texts even include maps of parts of the island. But unfortunately, these maps describe different regions of Atlantis. Your friend Bill has to know the total area for which maps exist. You (unwisely) volunteered to write a program that calculates this quantity.
 

Input
The input file consists of several test cases. Each test case starts with a line containing a single integer n (1<=n<=100) of available maps. The n following lines describe one map each. Each of these lines contains four numbers x1;y1;x2;y2 (0<=x1<x2<=100000;0<=y1<y2<=100000), not necessarily integers. The values (x1; y1) and (x2;y2) are the coordinates of the top-left resp. bottom-right corner of the mapped area.

The input file is terminated by a line containing a single 0. Don’t process it.
 

Output
For each test case, your program should output one section. The first line of each section must be “Test case #k”, where k is the number of the test case (starting with 1). The second one must be “Total explored area: a”, where a is the total explored area (i.e. the area of the union of all rectangles in this test case), printed exact to two digits to the right of the decimal point.

Output a blank line after each test case.
 

Sample Input
  
  
2 10 10 20 20 15 15 25 25.5 0
 

Sample Output
  
  
Test case #1 Total explored area: 180.00

这个题是一个扫描线的问题,给出几个矩形,问面积,思路就是从下至上扫描,到每一个新的横线就计算之前这段面积,如果从下至上沿Y轴扫描,就离散横坐标,有点复杂,也是看了其他好多博客才懂,写了好几次。。。

#include <stdio.h>
#include <string.h>
#include <algorithm>
#include <iostream>
using namespace std;
#define lson l,mid,i*2
#define rson mid+1,r,i*2+1
const int M=110;
struct LINE
{
    double l,r,h;
    int f;
} line[M<<1];
struct node
{
    int l,r;
    double h;
    int cnt;
} tr[M*8];
double pos[M<<1];
double ans;
int k;
int cmp(LINE a,LINE b)
{
    return a.h<b.h;
}
void build(int a ,int b ,int i)
{
    tr[i].l=a;
    tr[i].r=b;
    tr[i].h=0;
    tr[i].cnt=0;
    if(a==b) return ;
    int mid=(tr[i].l+tr[i].r)/2;
    build(a,mid,i*2);
    build(mid+1,b,i*2+1);
}
int query(double key ,int low, int high)
{
    while(low<=high)
    {
        int mid=(low+high)>>1;
        if(pos[mid]==key) return mid;
        else if(key<pos[mid]) high=mid-1;
        else low=mid+1;
    }
    return -1;
}
void cal(int val ,int i ,int n)
{
    if(tr[i].cnt==0&&val==-1)
    {
        tr[i].cnt=val;
        tr[i].h=line[n].h;
        return ;
    }
    if(tr[i].cnt+val==0)
    {
        ans+=(pos[tr[i].r+1]-pos[tr[i].l])*(line[n].h-tr[i].h);
        tr[i].cnt=0;
        tr[i].h=0;
        return ;
    }
    tr[i].cnt+=val;
    return ;
}
void updata(int l,int r,int i,int val,int n)
{
    if(tr[i].l==tr[i].r)
    {
        cal(val,i,n);
        return ;
    }
    int mid=(tr[i].l+tr[i].r)/2;
    if(r<=mid)
        updata(l,r,i*2,val,n);
    else if(l>mid)
        updata(l,r,i*2+1,val,n);
    else
    {
        updata(lson,val,n);
        updata(rson,val,n);
    }
}
int main()
{
    int Case=0;
    int n;
    while(~scanf("%d",&n)&&n)
    {
        k=0;
        for(int i=0; i<n; i++)
        {
            double x1,x2,y1,y2;
            scanf("%lf%lf%lf%lf",&x1,&y1,&x2,&y2);
            line[k].l=x1;
            line[k].r=x2;
            line[k].h=y1;
            line[k].f=-1;
            pos[k]=x1;
            k++;
            line[k].l=x1;
            line[k].r=x2;
            line[k].h=y2;
            line[k].f=1;
            pos[k]=x2;
            k++;
        }
        sort(line,line+k,cmp);
        sort(pos,pos+k);
        int m=1;
        for(int i=1; i<k; i++)
            if(pos[i]!=pos[i-1])
                pos[m++]=pos[i];
        m--;
        build(0,m,1);
        ans=0;
        for(int i=0; i<k; i++)
        {
            int l=query(line[i].l,0,m);
            int r=query(line[i].r,0,m)-1;
            updata(l,r,1,line[i].f,i);
        }
        printf("Test case #%d\n",++Case);
        printf("Total explored area: %.2f\n\n",ans);
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值